Community Forum

I need to change the apartment number on my address, please help me with that

New Poster

I need to change the apartment number on my address, please help me with that

My router and modem are to be delivered today and i really need to change the account number on that.

Highlighted
New Poster

Re: I need to change the apartment number on my address, please help me with that

Had a similar issue and I feel your pain. Took me four days and countless 30 min + calls with Xfinity support agents to get service activated. Just a quick synopsis of my issue and how it was resolved. Hope it helps and goodluck!

 

Services were initially activated one day before set move-in date at old unit. Picked up internet modem and two cable boxes from the local Xfinity store. On final walkthrough of initial unit, serveral maintence issues were present. Was not pleased with the condition of the unit for the price being paid. Was switched to a suitable unit that was in good condition (same complex). First night upon move-in, tried to self-install via xfinity X-fi app. Was given an error messaage telling me to call the 1-800 Xfinity # after choosing the proper unit. Was on the phone for 30 minutes and was directed to call the "movers" department in the morning because they were closed.

 

Day 2: Contacted the "movers" department at 8:01 AM and was informed that everything should be good to go. Got home from work, 7 PM and no service at all. Unable to do self-install. Called support and had a very dedicated agent (TY Coy) that promised me a call-back in the afternoon around 1 PM and that she would be working on this issue. Was informed that equipment was still registered to the old unit # and required a special department to clear out the registration info on the devices and register them to the new unit #. That department is only open from 10-6 PM (of course) so it would take another day.

 

Day 3: Received call-back from agent around 1:40 PM to let me know she was working on the issue and was speaking with the department responsible for clearing out registered info on the devices. Received another call from Agent around 2:30 PM letting me know that I was good to go, connection was showing up as working on her end, and that the old info was successfully cleared with new unit registration was transferred to the current devices. Arrived home after work around 7 PM and you guessed it, no connection. Called support again, expressed my displeasure with this entire experience, and was informed that an agent would have to come to my unit in-person to complete the installation process to get services up and running.

 

Day 4: Tech arrives and discovers that the coax ports were not active. His term was that the ports need to be made "hot". My interpretation of this is that service was not running through them. He connected 3 different ports via a box in the apartment (like a breaker-box). Finally, services are active and working. Still having issues with terrible internet speeds and disconnects, but its better than nothing. Hope this helps and take care.