Community Forum

How do I submit a request?

Sweetpotaytoes
New Poster

How do I submit a request?

Hi, We live in Houston and have been without power and service for days. I have been searching all over the Xfinity site for a way to submit a refund request, but haven’t gotten anywhere productive. Please help me! Each response I see on this forum says to click on the username and “send a message,” but I haven’t yet seen an option to send a message to anyone. Am I missing something?
ComcastChe
Official Employee

Re: How do I submit a request?

Welcome to the Xfinity Forum, and thanks for posting your question, @Sweetpotaytoes. I'm happy you found a way to contact us. You've reached a really awesome team, the Corporate Digital Care Team, and we are glad to help however we can! To answer your question, before you can send a private message to get assistance, you must first create a public post with details of your experience. Once you have done so, an official member of our team can assist you. Sending unsolicited private messages goes against the forum guidelines. Since you are a new poster, I wanted to provide you with this link, which will help answer any other questions, and provide step-by-step directions of how to do things here on the Forum.  

 

I'll be more than happy to help review your account and help with your refund for the time you were without service. Please send a private message by clicking on my name, "ComcastChe," and then click send a message. Please include your first and last name, the account holder's name if different from you, and the numbers associated with your service address.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Sock2
New Poster

Re: How do I submit a request?

I had no lights,no cable , far 4 days
BigTex2
New Poster

Re: How do I submit a request?

I have this same problem too. I do not have the function to submit messages either.