Community Forum

Returned Equipment, didn't get the promised $50 credit, and I am getting billed for the equipment.

Highlighted
Regular Visitor

Returned Equipment, didn't get the promised $50 credit, and I am getting billed for the equipment.

I stopped using the Comcast modem months ago.  I got an email from Comcast that if I returned the modem, I would get a $50 credit to my account.   I promptly returned it several weeks ago.  

What happened was:

 

1)  I was NOT credited the $50

2) I am still being billed for the returned equipment

3) I have been getting billed for the return equipment for months after I stopped using it!

 

So instead of geting a credit, I'm actually getting billed an excessive amount for the equipment I returned and stopped using months ago.  And the online chat is worthless!  It just says I don't have any credits pending on my account despite the email from Comcast that says I would get a $50 credit for returning the equipment, which I did a month ago.  And instead I'm still getting billed for it.  Very frustrating.

Highlighted
Expert

Re: Returned Equipment, didn't get the promised $50 credit, and I am getting billed for the equipmen


@SeniorEngineer wrote:

I stopped using the Comcast modem months ago.  I got an email from Comcast that if I returned the modem, I would get a $50 credit to my account.   I promptly returned it several weeks ago.  

What happened was:

 

1)  I was NOT credited the $50

2) I am still being billed for the returned equipment

3) I have been getting billed for the return equipment for months after I stopped using it!

 

So instead of geting a credit, I'm actually getting billed an excessive amount for the equipment I returned and stopped using months ago.  And the online chat is worthless!  It just says I don't have any credits pending on my account despite the email from Comcast that says I would get a $50 credit for returning the equipment, which I did a month ago.  And instead I'm still getting billed for it.  Very frustrating.


You say you stopped using the modem months ago, but then only returned it several weeks ago.  You should have been billed for the modem as long as you had it in your possession, whether you were using it or not.

 

When you returned the modem did you get a receipt for it?  That receipt will help you getting the modem removed from your account and stopping further billing, however, you won't get a credit for the time inbetween stopping using it and when you returned it.

 

As far as the $50 credit I can't help with that; maybe an Official Employee will step in and comment about it.


I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Regular Visitor

Re: Returned Equipment, didn't get the promised $50 credit, and I am getting billed for the equipmen

Yes, this is something that only Comcast can help fix with my bill.  And the online automatic chat is worthless.

 

I received an email about the $50 credit and quickly shipped the modem back a few days later.  There is no receipt involved.  I used the UPS label they provided, and the "return equipment" feature on Xfinity website shows that the return of the equipment completed.  Instead of a $50 credit, I got billed for another full month of rental on the equipment thas shown as received on the Comcast site for a while now:

 

Return #17758XXXXXXXX

Return Completed
 
 
 

 

 
 
Reminder: You're eligible to receive a $50 credit when you return your inactive internet equipment
 
Device serial number: XXXXXXXX
 
For a limited time, we are offering a $50 credit on your Xfinity account as our thank you for completing this return promptly*. You have less than two weeks left to take advantage of this offer. Please return your old equipment as soon as you can.
 
 
Highlighted
Expert

Re: Returned Equipment, didn't get the promised $50 credit, and I am getting billed for the equipmen

@SeniorEngineer 

Your issue has been escalated to the Comcast Corporate Team available to the Forums.  A member of that team will reply to your post as quickly as they are able, so check back often.
 
In the meantime, please do not send a PM to an Official Employee unless requested because it is against the Forum Guidelines and the Acceptable Use Policy.  

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
Official Employee

Re: Returned Equipment, didn't get the promised $50 credit, and I am getting billed for the equipmen

Greetings, @SeniorEngineer! I appreciate you taking the time to reach out to us here on the forums. I hope you are having an amazing day! I apologize to hear of the issues you are having with getting this $50.00 credit and the equipment removed from the account. I can certainly make sure we are getting this taken care of for you. Can you please send me a PM with your first and last name so I may further assist you?

 

To send a private message, please click my name "ComcastMichael" then select "Send a Message" on the right side.


I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!
Highlighted
New Poster

Re: Returned Equipment, didn't get the promised $50 credit, and I am getting billed for the equipmen

I’m currently on the phone with Comcast being treated like I’m crazy and as if that email never happened. But I received several of them about the $50 credit. Never got the credit
Highlighted
Regular Visitor

Re: Returned Equipment, didn't get the promised $50 credit, and I am getting billed for the equipmen

I was credited the $50 right away after being engaged by Comcast on this forum and providing requested account info, so it turned out well for me.

 

I shipped the modem on Sept. 3rd.

Comcast received  Sept. 8th.

$50 credit shows applied Oct 9th.

 

Thanks everyone.