MikeRubin's profile

Frequent Visitor

 • 

11 Messages

Wed, Dec 2, 2020 4:00 PM

Xfi won't properly reserve IP address for device; printers show as unconnected

I just switched from a third party router to the xfi gateway.  I hate that there's no network map, that only MAC addresses rather than common language names show on the connected device list, and that I can't change host names in the edit dialogues, but I was allowed to change the LAN address to its previous state (192.168.0.x), and the gateway is working okay with two exceptions:

 

(1)  I tried re-reserving at the same IP addresses the MAC addresses of devices that I previously reserved.  Everything seems to be okay on that score except for one device, which keeps reverting to the same DHCP-assigned address.  With my old router, it was at 192.168.0.6, but now it's always at 192.168.0.246, even after the assignment page tells me it has saved the new address.  I have disconnected the device from the network and, after ten minutes or so, can tell the phone app to "forget this device," but it always comes back on at the same 192.168.0.246 address.  My old router would allow me to disconnect and forget a device instantaneously, but this one doesn't seem to do that, and "forget this device" definitely doesn't work.  (I note that others posting in this forum have had the same issue and there's been no solution posted other than to try "forget this device."  There must be something we can do to make this a useful option.)

 

(2).  My two printers definitely are connected to the network as I have been able to print off to them from my computer and can ping them, but the router interface, the Xfinity webpage, and the Xfinity app all show them as disconnected.  How can I get them to be recognized as connected?

Responses

New Poster

 • 

1 Message

3 m ago

After talking/chatting with 8 technicians and replacing my router once, I finally learned that reserved IPs are only allowed for business accounts, not home users like me.

I got the first one to work, but when trying to reserve a 2nd IP, clicking simply returns me to the previous Devices screen or results in an Alert: Failure, Please check your inputs and try again. and then simply leaves it on DHCP.

jlavaseur

Valued Contributor

 • 

411 Messages

3 m ago

If your gateway is setup as mine was the dhcp range started at 192.168.0.2, well that leaves no room for static ips, adjust it to start for example, 192.168.0.15, that leaves you 192.168.0.2 thru 192.168.0.14 for static ips, adjust accordingly

Frequent Visitor

 • 

11 Messages

2 m ago

@jlavaseur, I am a bit confused.  I was talking about reserved IP addresses, not static IP addresses, which typically are set in the connected device.  If I start DHCP at 192.168.0.50, I can't reserve anything below that address because it is out of range, but, if I try to reserve above that address, I either get the same error message as @rthornt or one indicating that I already have reserved that address for another device (which is not true). 

I like the xfi's performance, but, after years of using Linksys, Netgear, and ASUS routers, I think the xfi's interface is really, really both primitive and confusing.

jlavaseur

Valued Contributor

 • 

411 Messages

2 m ago

ok, sorry about the confusion, i think there is a bug, try when setting the reserved ip, in the comment box you have to put a word, one word only, then it seems to work

Visitor

 • 

1 Message

2 m ago

I was having the same error. It was maddening. What works is a SINGLE word in the comment section. The word can contain underscores, such as Hello_World but there can't be any spaces. Software engineering at its best.

New to the Community?

Start Here