mdephillips2020's profile

New Poster

 • 

1 Message

Tue, Dec 15, 2020 4:00 PM

xFi Pods only work when connected via wired Ethernet

So I've had xFi pods since the summer.  I have three and they have worked great.  Last Tuesday (December 😎 devices would no longer connect to the Internet via an xFi Pod.  I found laptops, iPhones, Chromebook and iPads would not get an IP address from the cable modem which is acting as my DHCP server.  These devices get a 169.254.x.x IP address.  The devices and the xFi Pods show connected in the Xfinity Connect app.  The devices show they have the correct IP address for my network on the Xfinity app and the cable modem.  I can't ping them.  The devices will only connect to the Internet when connected to the WIFI access point built into the cable modem.  If I put a static IP address on my mobile devices they still won't connect to the Internet via an xFi Pod.  I've tried removing and unplugging and reinstalling the xFi Pods multiple times.  I even rebooted and power cycled the cable modem.  Xfinity sent me a new XB7 cable modem but that didn't solve the problem.  Today I noticed if I plug my laptop into the wired Ethernet port on an xFi Pod I can get an IP address and browse the Internet.  Any ideas?

Responses

No Responses!

New to the Community?

Start Here