MannyMack's profile

New Poster

 • 

3 Messages

Tue, Nov 3, 2020 7:00 PM

Xfi Gateway Modem Power Light

Plugged in my recently received Arris TG1682G modem in functioning power outlets. Should there be a power light showing? If not, is the device defective and what is the next step to get a functioning Xfi Gateway modem?

Responses

Accepted Solution

darkangelic

Expert

 • 

2K Messages

6 m ago


@MannyMack wrote:
Plugged in my recently received Arris TG1682G modem in functioning power outlets. Should there be a power light showing? If not, is the device defective and what is the next step to get a functioning Xfi Gateway modem?


That's not a good sign. There are several LEDs in the front of the XB3 (TG1682G) that should light up, including one for power. 

You can bring it down to your nearest Comcast store for an exchange, or you can arrange for a swap by phone using (800) XFINITY or by chat.

Or even here, if you so wish, in which case I'll have a Comcast rep take it from here.

 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

3 Messages

6 m ago

Thank you very much for your assistance.

New Poster

 • 

3 Messages

6 m ago

Drats. I meant to mark your answer as "best answer". Not my own post. I hope that can be fixed as well.
EG

Expert

 • 

86.5K Messages

6 m ago

For curiosity, does it get online ?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here