JavaJed1's profile

Frequent Visitor

 • 

6 Messages

Thu, Dec 10, 2020 6:00 AM

Xfi Gateway forcing all devices to connect to 2.4ghz network, no longer getting 5ghz speeds

I've seen many posts related to this issue, but no solutions other than "buy your own equipment", but I'm hoping someone has found a solution that works with the Xfi Gateway.

 

I used to have two wifi networks with two different names, one using 2.4ghz, and one using 5ghz. A little while ago, the 5ghz network disappeared from all of my devices. The only way to get it back was to reboot the Gateway. But it would always dissappear again.  Turns out the Gateway changed it's settings to automatically manage the wifi settings, and is now combining the 2.4ghz and 5ghz networks to "optimize" my home network. It should supposedly automatically determine the best connection for my devices. OK, sounds great in theory, but I end up with much slower connection speeds. I'd get 50-80mbps, rather than the 500mbps I used to get.

 

I thought the issue might be that the 2.4ghz and 5ghz networks had different names, so I gave them both the same name, as recommended by the Xfi app. This made no difference. So I changed the networks to have different names again, and rebooted. For a few minutes, my 5ghz network came back, and I was able to connect to it. Ran a speed test and got around 600mpbs. But after a few minutes, the network disappeared and I was only able to get a slower connection. So I changed the network names again to be the same and rebooted the Gateway.

 

After rebooting, I again showed one network, which was expected because I gave them both the same name. I connected to the network and immediately ran a speed test, and hooray, I was getting 5ghz speeds again! I thought it was solved, but a little while later I ran a speed test again, on multiple devices, and was only getting 2.4ghz speeds on all of my devices.

 

I've read older posts about this issue where people suggested going into my Xfi app advanced settings and manually splitting the two networks, BUT, since the Gateway is now managing my wifi settings automatically, I no longer have that option. And there is no way to turn off this auto "feature."

 

My work computer, which is connected via ethernet, gets fantastic speeds (faster than Gigabit). But everything else in my home connects by wifi and is stuck with 2.4ghz speeds, whether I'm in another room 20ft away, or standing right in front of the Gateway.

 

Anyone have any solutions to this, aside from buying my own modem and router? I may end up going that route, but there should be some solution using the Gateway. I pay a lot for my service, and I'm not getting what I paid for. It almost seems like Xfinity is purposely forcing the 2.4ghz connection as an underhanded, backdoor way to reduce my data usage.

Responses

EG

Expert

 • 

87.1K Messages

6 m ago

Frequent Visitor

 • 

6 Messages

6 m ago

Unfortunately, no. My settings are set to "Auto", so I'm not able to take any of those steps, and there's no way to change it from "Auto" to "Manual."

EG

Expert

 • 

87.1K Messages

6 m ago

Oh well. Sorry it doesn't help. I don't make policy. Good luck to you !

Visitor

 • 

1 Message

3 m ago

Any resolution to this? Mine is currently doing the same thing.

EG

Expert

 • 

87.1K Messages

3 m ago

@user_c360d2 

Please create a new topic of your own here on this board detailing your issue. Thanks. 5 month old dead now being closed.

New to the Community?

Start Here