Thelight1's profile

New Poster

 • 

5 Messages

Sun, Jan 3, 2021 11:00 PM

XB7's 802.11ax/Wi-Fi 6 functionalities?

Hi,

I just recieved an XB7 and noticed that it seems the ax/Wi-Fi 6 functionality isn't available.  I ran some tests using the app/Xfinity XFi webpage on a desktop, and the admin tool on a desktop.  

First, under View Network Details > See Network > Advanced Settings > 2.4 and 5 GHz WiFi, I changed the WiFi modes for the 2.4 and 5 GHz networks.  But everytime I change the mode and click SAVE, it doesn't change.  Note: the Channel Width and Channel Select do change after saving the settings.  Here is where things get interesting...

 

On the Admin Tool, I'm able to change the 2.4 GHz network to G,N,AX and the 5GHz network to A,N,AC,AX, but using some WiFi analzying tools on dektop, it shows that this change only affects the "hidden network," enabling that "hidden network" to be WiFi 6.  My normal network SSID stays at WiFi 5 no matter what.  I also went in and wanted to see if the app/Xfinity XFi changed the admin tool settings, and vice versa.  From the tests, it seems that the channel width and channel number do change on the admin tool and app/XFi page respectivly, with some exceptions such as, the app has 80/80 bandwith, and the admin tool doesnt, so it's greyed out from really selecting on the app.  But any change of WiFi mode on the app doesnt change the admin tool's WiFi mode settings.  So it seems that the WiFi Mode is stuck as the hidden network only.  I wonder if this is because WiFi 6 is still fairly new.  Anyone have any insight?  Also, it seems that WPA 3 is an option under the app, but not in the admin tool, and any attempt at selecting and saving it, will not save/work on the app anyway.  Thanks guys!

Responses

New Poster

 • 

5 Messages

5 m ago

So ultiamtly it seems that the XB7 is basically a WiFi 5 device until WiFi 6 functionality is enabled, interesting since the XB7 was touted as a WiFi 6 certified device.  This all becomes confsuing since the App and Admin tool both use old nomiclature instead of WiFi 5 and 6.  The biggest concern is with AX (Wi-Fi 6) turned off for 2.4 and 5 GHz frequencies, I'm wondering if the XB7 is still using things such as OFDMA. Using WiFi 4 on 2.4 GHz and WiFi 5 on 5 GHz is basically what it seems like the XB7 is doing.  The lack of OPDMA is concerning since the number of devices running off of the XB7 will be constantly increased over the next year or so.  Using the admin tool of the XB6 does not include AX for 2.4 and 5 GHz, while the XB7's does, but obviously we're nto able to turn this on.  My best guess is that WiFi 6 will be enabled with this device in the future.  Does anyone know if OFDMA still works with the 2.4 and 5 GHz bands being WiFi 4 and 5 only?

jlavaseur

Valued Contributor

 • 

432 Messages

5 m ago

It was enabled by default on my Xb7, I don't have the option of changing those settings on mine,  they are grayed out, anyway I read a post with a guy having the same problem, I think he logged unto had gateway with 10.0.0.1 and changed it there, he didn't use the Xfi app, 

EG

Expert

 • 

87.1K Messages

5 m ago


@Thelight1 wrote:

I'm wondering if the XB7 is still using things such as OFDMA. Using WiFi 4 on 2.4 GHz and WiFi 5 on 5 GHz is basically what it seems like the XB7 is doing.

 

 Does anyone know if OFDMA still works with the 2.4 and 5 GHz bands being WiFi 4 and 5 only?


OFDMA is exclusively a function of the WiFi 6 / AX protocol.

jlavaseur

Valued Contributor

 • 

432 Messages

5 m ago

 

I dont know if can you read this, mine are grayed out and i cant change them, but mit shows ax

 

New Poster

 • 

5 Messages

5 m ago

Thank you Jlavaseur, That's very interesting that yours is greyed out and WiFi 6 bu default.  I logged into 10.0.0.1 admin tool, and changed it in there as well, but it only changes the hidden networks to WiFi 6.  So does your admin tool and app show 802.11AX as being enabled by default?  Would you be able to take some screenshots?

New Poster

 • 

5 Messages

5 m ago

Thank you, EG.  Not sure how to include both replies to both of you on here in the same reply.  So I wonder if it's just my area, as both my cousins' XB7 and mine both are not enabling WiFi6, but jlavaseur said theirs was enabled by default.

New Poster

 • 

5 Messages

5 m ago

Thank you.  Wow so yours is managed fully by Xfinity it seems, and mine isn't as mine is fully editable on the Admin Tool.  Which would be fine, but changing the "Mode" only affects the hidden networks for some reason.  I wonder if it's just your region that is managed fully by Comcast.  I would love to run a WiFi explorer tool to see if your router is using WiFi 6, or if it's just your hidden networks like mine.

New to the Community?

Start Here