Stormshift's profile

New Poster


2 Messages

Wed, Sep 30, 2020 5:00 PM

XB7 & Gigabit - 5Ghz stuck in 20Mhz - Grey Settings

I will break this down into two parts. 
Part one is my initial problem, and what I did to try and remedy it, my progress, and hopefully someone here can tell me if everything looks alright.

Part two is my current problem that occurred AFTER my initial problem, and I have made no progress nor have any clue on possible causes or fixes. Help on this would be AMAZING. 

Note: That while both parts bother me, part two is where I am stuck and really need help. Part one is for confirmation that I covered all my bases.


I have been struggling with this for months now. If anyone would be nice enough to look over this, and give me any input or suggestions, I would GREATLY appreciate it.


[PART ONE - Initial Headaches]

I currently have Gigabit service with the new white XB7-T gateway. I had to upgrade since my black XB6 was giving massively high numbers of Uncorrectables on all channels, and frequent disconnects almost hourly. My speeds after installing the new XB7 were terrible.


I do ALL of my testing on either my desktop or laptop, both Win10, both hardwired via Cat6e gigabit ports. I've tried different NIC drivers, different Cat6e cables, and reformatted Windows to a fresh install just to make sure they weren't the issues. I also took all other devices offline/airplane mode so ONLY the PC would be online.


[PART ONE - Setup & Changes]

I then moved the XB7 from the back room where they originally installed it, to the main living room. It is a more central location, I also wanted to do this anyway for better WiFi coverage. I have runs of Ethernet for my desktop PC, so no worries there.

I also went outside where our orange cable comes out of the ground and checked the cable and connectors. Its dirty of course, but looks fine from what I can see. I then decided to remove all runs of coax cable Comcast installed during our initial setup about 4 years ago. This was a new house with no existing coax installed at the time. I then replaced the runs with fresh coax/connectors just to rule out they may be the issue.

Currently my setup is:

  • One 2-way 3.5db splitter off the incoming drop.
  • One run of new coax off drop/splitter going to the main living room. 2nd port on splitter is capped.
  • On the new coax run, I have one 3.5db connector, continuing with more coax.
    • PS. I only added the 3.5db connector to move my signals closer to 0+/-. I tried removing that and just doing a single run to gateway from drop/splitter, which didn't improve anything.
  • Coax then runs directly into the XB7 gateway.


I then did multiple complete factory resets of the modem. I tried activating it from the xFi app with no devices connected, and from the welcome setup hardwired from PC.  I also let the latest firmware update before continuing. I then used separate SSIDs/passwords each time so nothing could be in "memory limbo" and somehow mess with something.


[PART ONE - Progress]

After doing all of that, I finally got acceptable hardlined speeds, although ONLY on the xfinity speed test. It shows 700-900Mbit download, 45Mbit upload. Any other speedtest site seems to pull 300-600Mbit down, 40Mbit up. Of course, my WiFi devices are all over the place, which I expect given their hardware/distance. Anywhere from 40Mbit to 350Mbit depending on the device. I expect variance in WiFi, not so much from wired. I do understand if there is another laptop online and a smart tv streaming shows when I do the speedtest, pulling 600Mbit on wired is probably good. (?)


I finally got the disconnects under control, and the massive uncorrectables seem to be better. Zeros across the board aside from Channel 16, which has a 50% Correctable/Unerrored rate, and only 256 Uncorrectables after 27 hours of uptime.


[PART ONE - Logs]

I don't see where you upload photos, so I'm going to link to it. The following picture is the gateway admin page. Hopefully someone can tell me if those values look acceptable. - Screenshot of Gateway Status 


[PART TWO - Lil Moe and his gimpy WiFi]

This is where I am baffled. I hit a total standstill when I realized a handful of my devices just won't connect anymore. No matter what I do they refuse to connect. I suspect it has something to do with the connection type.

My VR headset manages to connect via 5Ghz, but the speed is terribly slow, even within direct line of sight of the gateway (within a few feet). I tried using a single SSID but the gateway has a terrible time of putting devices on the right band.


[PART TWO - Keep 'em Separated]

I decided to separate the SSIDs for the 2.4Ghz and 5Ghz bands. After doing that, I was able to get my devices connected. (Yay!) However, I still noticed extremely slow speeds. You know what, at this point, I understand it on the 2.4Ghz band, and am willing to accept it. The channels are flooded anyway. Problem is, I can't accept it on 5Ghz AC/AX as it makes playing VR nauseating.

I tried taking all devices off the 5Ghz channel, pausing, airplane mode, and turning off anything I could. I put only the Quest on the 5Ghz channel, and still couldn't get an acceptable connection without constant stutters/freezes. I know the headset is capable of 5Ghz AC @ 867Mbs as plenty of other people run it fine at that rate. Again, this is all within feet/LoS and the only device online.


[PART TWO - You Shall Not Config]

At this point I thought it was something gaming related, so I asked some discord boards. They suggested I drop the AX/WiFi6 mode, and consider changing channels to something less congested. Guy even showed me a picture of his Comcast settings, using the same XB7 modem & gigabit. Yet when I go into my admin panel, all my settings are GREY. I can't change a single thing. It only lets me change WiFi name/password within the xFi app, and thats all.

So I can't change to WiFi5/AC only mode. I can't change the channel to something less congested. In fact there is empty channels according to WiFi Analyzer, but all my Comcast neighbors cram onto the same channel.

The most surprising part is the web panel shows BOTH 2.4Ghz and 5Ghz are locked onto 20Mhz Width mode, with no way to change it. 


I've tried restarting the gateway, refreshing WiFi module, connecting ONLY one device to the entire network. Hiding/Unhiding the SSID from broadcasting from the xFi app. Nothing works. 

Yet somehow people with this same gateway from comcast are able to edit their settings, as I've seen screenshots of them unlocked and not grey. I will link a screenshot of my WiFi settings so you can see what I mean. - Screenshots of 5Ghz & 2.4Ghz Settings 


[CONCLUSION - Save Me 😭]

If anyone has any idea how to fix this, please help. I called Comcast support multiple times, and trying to explain all this along with everything I tried causes Level 1 to just glaze over and repeat the same thing. The few times I have been escalated to Level 2, I was hung up on, or put on hold then disconnected. After being on the phone for 2+ hours and getting disconnected each time, I am at my wits end.


Whoever figures this out will be my hero. I'll be your best friend! Maybe even treat you to dinner? 🤗

Thank you all!



Valued Contributor


417 Messages

8 m ago

I got this info from another post I was following, the poster claimed that if you activate the Xb7 gateway from the Xfi app it grays out the options, if you activate it from it leaves them adjustable,I can't verify this as I activated from the Xfinity app and mine are grayed out, but my gateway works awesome, fast speeds and no disconnects, but looking in my admin panel the bandwidth is set to 20/40/80 even tho grayed out which is what I had set on my Xb6

Official Employee


2.9K Messages

7 m ago

Greetings, @Stormshift! I appreciate you taking the time to reach out to us here on the forums. I hope you are having an amazing day! I apologize to hear of the issues you are running into when it comes to the connection and speed of your internet. I would like to have a look into the connection to see what's going on. Can you please send me a PM with your first and last name so I may further assist you?


To send a private message, please click my name "ComcastMichael" then select "Send a Message" on the right side.

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick



29 Messages

6 m ago

Get a new xb7 modem and tell the person at the store to activate it for you. That’s what the lady told me when she gave me mine and my settings are not grey. I also DID NOT add the xFi pods. Once you do I don’t think you can “ungrey” the settings. When I had the old XB6 and they rolled out merge of WiFi signals I did it and it greyes out my settings. Do NOT merge the WiFi either. Well that’s what I did

Frequent Visitor


23 Messages

6 m ago

I Activated my XB7 Gateway via the Xfinity App,  ported over settings from my old XB3 Gateway,  unforuately i can't split the wifi signals i don't think, 2.4ghz/5ghz must be same name/password i think for my Wireless TV box on my TV for that to work.        


Unforuately then i can't change Channel bandwidth at all like others,  or Wireless Channel, or Wireless Mode, but i do have some wireless AX devices so speed isn't much of a problem at all


Firmwire on mine is 4.4P9s2 currently i believe


New to the Community?

Start Here