mpg3's profile

New Poster

 • 

2 Messages

Sun, Aug 9, 2020 10:00 AM

Wifi Speeds

Greetings.  If anyone can help me troubleshoot, or point me to a good forum item, it would be greatly appreciated.

 

I have xfinity giga service through an Arris SB8200 modem.  The wired speeds are good, to my PC.  800 mps +/-.

 

Connected also is a Linksys EA9500 wireless router (giga capable).  Not bridged.  Getting about 20 mps download to mobile device with no interfering building structures.  Beyond that location even worse.

 

I'm not a network expert by any stretch.  Any suggestions?

 

Many thanks in advance.

 

MG

Responses

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

9 m ago

Have you tried linksys Support, it’s their equipment
https://www.linksys.com/us/support/

New Poster

 • 

2 Messages

9 m ago

Thanks for your reply.

 

The standard tips for networking setup, like those on the linked xfinity site, have already been considered.  I'm guessing that I'm missing some fundamental fix, not of the garden variety, that solves the problem of a wireless environment that is dropping 700 mps wired speeds down to 20 mps wireless.  I appreciate the reference, though.

 

The equipment is mine....but recommended by xfinity for this giga service.

 

Thanks again.

 

MG

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

9 m ago

The equipment isn’t recommended, the list is telling you what’s compatible with gig service. You’ve proven the modem is getting the speeds it should. The problem is speed loss/connection issue between modem and router, which is where the manufacturer support comes in. Comcast can only troubleshoot so much with third party equipment. A tech coming out to troubleshoot would tell you the same thing but with a service charge attached.

New to the Community?

Start Here