mgjunk's profile

New Poster

 • 

2 Messages

Thu, Dec 10, 2020 5:00 AM

Wifi connection issues ever since upgrading to Technicolor CGM4331COM

Ever since I upgrade to a faster interent and Xfinity sent me their Technicolor CGM4331COM modem/router, I've been having problems with multiple devices connecting via wifi. My kids XBOX 360 will no longer connect and now my Dell Inspiron 15 5000 Series laptop doesn't even display the networks. There is no way obvious for me to contact Xfinity support via email and I don't have time to spend an hour on  the phone with them to trouble shoot. I either want exact step by step layman's terms instructions to resolve the issue or send me a new router/modem that works.

Responses

New Poster

 • 

2 Messages

5 m ago

Thanks for the response, but it wasn't quite layman's terms. When I look at the available connections from the devices that work, I see 2 different newtowks; one for 2.4 and the other 5 so I assume they are already split. However, I don't see either of these networks available on the devices having the problems. 

EG

Expert

 • 

86.6K Messages

5 m ago

The two WiFi bands have recently been combined into one with the Comcast gateway devices. Some devices get confused and don't know how to see / talk to combined bands.


If you are not using any Xfi Pods, you can try separating the 2.4 and the 5.0 bands and give them two different broadcast names / SSID's;


https://www.xfinity.com/support/articles/change-wifi-mode-admin-tool-xfinity-xfi


Associate the devices with the 2.4 or the 5.0 (whichever one works) band's SSID (broadcast name) and password.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
Curly

Contributor

 • 

35 Messages

3 m ago

I am having the same issue. They make it look so easy switching out routers but I knew we would have problems. I was on the phone for an hour trying to get up and running. After several attempts we finally got the router working with TVs and laptops but my printer will not connect.  This happened the last time we swtiched routers. The techs don't seem to know how to handle this and, like you, I don't want to spend a better part of my day on the phone.

New to the Community?

Start Here