bamu's profile
bamu
Expressive Exchange
Stamp of Approval
Conversation Starter

Frequent Visitor

 • 

17 Messages

Sun, Oct 18, 2020 6:00 PM

Why does my neww Xfinity modem/router keeps droppping my Envy wireless printer?

Why does my neww Xfinity modem/router keeps droppping my Envy wireless printer? Printer is always going offline,.....

Responses

Accepted Solution

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

7 m ago

It would be better to edit your Wi-Fi networks SSID to be separate with different names. Unless you have pods, then you won’t be able to

https://www.xfinity.com/tips/change-wifi-name-password
Again

Expert

 • 

25.5K Messages

7 m ago


@bamu wrote:

Why does my neww Xfinity modem/router keeps droppping my Envy wireless printer? Printer is always going offline,.....


What is the error message you get when it goes offline?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
bamu

Frequent Visitor

 • 

17 Messages

7 m ago

Not sure where I find an error message.

bamu

Frequent Visitor

 • 

17 Messages

7 m ago

Printer just says offline. And I don't see/can't find an error message on the printer..... I may just buy a Motorola and turn the Xfinity back in.

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

7 m ago

Are your wireless networks combined? If so, try splitting them
bamu

Frequent Visitor

 • 

17 Messages

7 m ago

I'm not real tech. I can find the info shown in the file below. Says everything is auto. Can I disable the 5?

bamu

Frequent Visitor

 • 

17 Messages

7 m ago

I found the way to give different names to the 2.4 and 5 networks so will try that. I know for a fact that my wireless printer will not work with 5!

bamu

Frequent Visitor

 • 

17 Messages

7 m ago

After I set up the 2 separate networks, I restarted the desktop and the printer. Still no luck. I then did a modem restart, and now it seems to be working. I hope it lasts!

New to the Community?

Start Here