MSRMafia's profile

Frequent Visitor

 • 

6 Messages

Wed, Mar 25, 2020 4:00 PM

Website Load Time Issues On Random Sites (Especially GoDaddy Hosted)

Over the past few months I've started to notice slower than normal load times on some websites using my Xfinity internet service (XB3 Gateway). Specifically I've pinpointed a lot of sites, which are hosted through GoDaddy.com having unpredictable loadtimes or even only partial loads.

 

Conversely, if I hotspot my Verizon phone and use that as my wifi source, the same sites all load immediately on all devices. Is there any chance that my Xfinity internet is encountering issues with the GoDaddy DNS? Any ideas for solutions?

 

I own a company with over a 100 sites hosted through GoDaddy.com so this gets very frustrating, when trying to build Wordpress sites and check updates. I've used Xfinity for the past several years, and never encountered this issue until the past few months.

 

Thanks greatly for any help.

- Ben

Responses

darkangelic

Expert

 • 

2K Messages

1 y ago

If you're using a Comcast leased gateway, the culprit could be xFi Advanced Security as it tends to be overly aggressive.  You can go to this link to disable it (requires XFINITY account logon).

 

https://internet.xfinity.com/more/my-services

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

2 Messages

1 y ago

Ben I am having the very same problem.  it is only Godaddy sites for the most part for me, while other sites work great.  even my FTP connection is very slow and cutting off about every 20 - 30 seconds. 

 

it is only an issue if I use my Xfinity interent too.  Godaddy claims they have no filters to stop or slow flow of information to or from ISPs.

 

I hope someone responds! this is pretty obscure and so it will likely be hard to find the right person that both cares enough to address this and to actually have a way to fix it.

 

this is terrible though.  I can't even perform simple updates to some sites.  in many cases I am blocked out from getting any data from a site 90% of the time.

MSRMafia

Frequent Visitor

 • 

6 Messages

1 y ago

I disabled the Advanced Security option yesterday evening (after reading one of your suggestions on another topic). It did seem to help a little, but still not much improvement.

 

I have four Xfinity HD boxes on different tv's in my house, an Xfinit fax line, plus the internet on my account, and I don't want to have to to think about a change in service, but I'm going to have to evaluate my options to go a different direction it if I can't get a resolution to this struggle in the near future.

 

Thanks again for the help.

- Ben

darkangelic

Expert

 • 

2K Messages

1 y ago

If you don't have the Home Security service, another option would be to just jettison the leased gateway completely and use your own modem and router. (I had done this for years because I was running a Plex Server and a SiliconDust HomeRun tuner, and I was having issues with connectivity).  You also save the $15/mo lease fee. 

 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
MSRMafia

Frequent Visitor

 • 

6 Messages

1 y ago

Maybe a stupid question, but if I went to my own modem and router, would I be able to run my fax line through my own modem. It currently runs through the Xfinity modem/router.

MSRMafia

Frequent Visitor

 • 

6 Messages

1 y ago

Thanks I may trying going that route if I can't find a comparable internet and tv provider replacement.

 

Again I really do appreciate your help.

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

1 y ago

You would need a modem with a phone port (like the gateway has).

New Poster

 • 

2 Messages

1 y ago

Identical issue out here in California. I'll let you know if I figure out a solution

MSRMafia

Frequent Visitor

 • 

6 Messages

1 y ago

I had hoped an Xfinity tech might supply additional insight but I'm guessing maybe they don't frequent these boards?

New Poster

 • 

2 Messages

1 y ago

I have my own modem router and am still having this issue.  a rep at xfinity said he could see traffic was being "throttled" by something in their system and created a ticket with advanced support with the promise this would get fixed within 24 hours.   nearly 3 days later I have not gotten a call from Xfinity of course.   things are still moving at a crawl.  ONLY godaddy sites, FTP connections too.  if I switch off of xfinity and on to cell phone hot spot it goes MUCH faster and I have a crummy cell phone signal out there. so I know my xfinity connection is bad.  just can't tell if this is something at Godaddy or Xfinity yet though. neither want to take the credit of course.

MSRMafia

Frequent Visitor

 • 

6 Messages

1 y ago

Thanks for the update. Definitely makes me believe it has to be on the Xfinity end of things... otherwise we'd have the same problem when we hotspotted our phones and connected to the sites.

 

If you hear/learn anything additional, please respond here, and I'll do the same.

 

Have a great day!

New Poster

 • 

1 Message

1 y ago

Yeah I'm having the same issue here. Just got off of chat with GoDaddy support, I ran a traceroute and requests are timing out at hop 6 and 7 for me, apparently this indicates a Comcast issue. As a test too, I switched off my phone's wifi and could navigate the site just fine using my cell network.

New to the Community?

Start Here