gypsyldy's profile
gypsyldy
Much Appreciation
Expressive Exchange
Stamp of Approval

Contributor

 • 

26 Messages

Tue, Nov 10, 2020 9:00 AM

WEAK SECURITY FROM INTERNET TO PHONE

Hi All....Need all of your expert's help once again!  

When I'm home, on my iPhone, it says my wi-fi' security is weak...It never has been before...then on my iPad, using the same internet modem, it doesn't show that it's weak????  Also, on the iPhone it says due to WPA/WPA2  (TKIP) is not considered secure...It says to configure the router to use WPA2 (AES) or WPA3 security type....I've tried "forget this network", etc. which was no help....How do i change it to WPA2 or WPA3???  And why is it fine on my iPad?????  Using the same Network??

Responses

New Poster

 • 

1 Message

6 m ago

I just saw the same thing today!
strega7

Regular Contributor

 • 

393 Messages

6 m ago

You may have different versions of IOS on your phone and iPad.  Apple only started making a fuss about this recently.  I use my own router so I couldn't tell you how to do it on Xfinity's.  It'll probably be right by where you set the SSIDs and passphrases for your wireless networks.

New Poster

 • 

1 Message

5 m ago

Visit 
https://www.xfinity.com/support/articles/change-wifi-security-mode
I used the xfinity.com/myxFi  Connect/See Network/edit (pencil top right on iphone) 

under security mode - change from WPA/WP2 to WPA2 (only) 

 

 

New Poster

 • 

2 Messages

4 m ago

I am having the same issue with my iPhone saying “ weak security “, but, only on my iPhone.
I called Xfinity and she ty old me to change my wifi network to one name instead of two names. I did that and it is still the same.

New Poster

 • 

2 Messages

4 m ago

Thanks, I will try that.
flatlander3

Regular Contributor

 • 

176 Messages

4 m ago

@gypsyldy 

 

iPhone update somewhere around IOS 14.1 (now IOS 14.3) complains about the WiFi using WPA/WPA2 (TKIP) for an encryption algorithm  -- That's where your 'weak security' message comes from.  WPA/WPA2 is now depreciated just like old-skool WEP security.   It's true.  If someone wants to spend the time cracking your WiFi password, it's possible to decrypt WPA/WPA2(TKIP).

 

If you can change the WiFi Security on your Gateway to use WPA2(AES) or WPA3 that message will go away -- and it's much more difficult to break your WiFi encryption. 

 

You can change the security mode algorithm on a lot of 3rd party Gateways, I'm not sure if the setting exists on Xfinity gear.  Take a look for manuals on the support site, or your gateway's manufacturer site to see if you have the option, or just go into the admin page on your gateway, and most of them place the option where you set your WiFi password.

 

Old devices, may not be able to connect when you change it, but most will.  Try it.  See if your stuff still works.  Unless it's really old, it should work. 

Official Employee

 • 

2.5K Messages

4 m ago

Hi everyone! Has anyone tried a factory reset on their modem to see if that helps? It might be a setting causing a weak connection.

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick
Gambit66

Problem Solver

 • 

314 Messages

4 m ago


@gypsyldy wrote:

Hi All....Need all of your expert's help once again!  

When I'm home, on my iPhone, it says my wi-fi' security is weak...It never has been before...then on my iPad, using the same internet modem, it doesn't show that it's weak????  Also, on the iPhone it says due to WPA/WPA2  (TKIP) is not considered secure...It says to configure the router to use WPA2 (AES) or WPA3 security type....I've tried "forget this network", etc. which was no help....How do i change it to WPA2 or WPA3???  And why is it fine on my iPad?????  Using the same Network??


@gypsyldy  (TKIP) is old encryption, AES is Best. Are you connected to the Comcast Modem/router/WiFi, or your own Router?

You have to log into your router and change the security settings on the GUI interface of your Router. You want to set it to WPA2 AES!

Regular Visitor

 • 

3 Messages

3 m ago

@Gambit66 , (or whoever can reply) I'm connected to my own router (TP-Link, a few years old) in bridge mode (which in turn connects to the Xfinity router). My router only gives me the following options for selecting the 'Security' setting: 'WPA/WP2 Personal' , 'WPA/WP2 Enterprise' or WEP. If I stay on the first, I have a choice of 'version' with possible values: 'Auto' (current), 'WPA-PSK' or 'WPA2-PSK', and also of 'encryption'  with values being 'Auto' (current), 'TKIP' or 'AES'. Would choosing for version 'WPA2-PSK' and encryption 'TKIP' be enough, or will it really not work unless the security selection was changed from 'WPA/WPA2-Personal'  (which, as I explained, does not seem to be much of an option for my router).

Gambit66

Problem Solver

 • 

314 Messages

3 m ago

@pgoldweic I'm connected to my own router (TP-Link, a few years old) in bridge mode (which in turn connects to the Xfinity router).

 

That makes no sense. Your personal router is in bridge mode and connected to the comcast router?

The Comcast modem/router should be in bridge mode when connnecting your personal router to it. 

As far as security setting for your WiFi. WPA2 Personal is the most secure, and auto sets to AES. 

Visitor

 • 

1 Message

2 m ago

how do you connect to your router?

jav6joev

Bronze Problem Solver

 • 

2.1K Messages

2 m ago

@user_9326bd  Exactly what are you asking?  Are you having issues connecting to your router, accessing the admin page or asking how someone else is connecting to their router?

EG

Expert

 • 

86.6K Messages

2 m ago

@user_9326bd 

Please create a new topic of your own here on this board detailing your issue. Thanks.  4 month old dead now being closed.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here