mstrvm's profile

Frequent Visitor

 • 

6 Messages

Tue, Sep 22, 2020 4:00 PM

Upgraded my plan from Performance Starter (25mbps) to Performance (100bmps) - but speed is same.

But here is the most interesting thing:

 

if I do a speed test on speedtest.xfinity.com - I get the full 100bmps

If I do the speed test on speedtest.net - I get the old speed. 

If I do the speed test on any other 3rd party speed test website, I still get the old speed.

I've performed the speed test on various devices - Laptop/Iphone/Samsung TV

I get same results - on speedtest.xfinity.com - close to 100mbps, on any other website - not more than 20-28mbps. Samsung TV via Netflix app doesn't go more than 16mbps.

I've been trying to speak and explain to Xfinity tech support, but they all tell me that My Wi-Fi is bad. If my wi-fi is bad, how come I get the 100mbps on speedtest.xfinity.com then, through the same wi-fi connection?

 

I factory reset the modem, not helped.

 

I'm not sure what might be the problem, but I get more frustrated each time when I call tech support...and as of right now, I already called over 4 times during the past 2 days...

Responses

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

7 m ago

All Comcast will worry about is the speed test on their site, it’s their server. They are not going to troubleshoot other websites. You’ve proven you’re getting what you’re supposed to be getting
CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

7 m ago

I’m just passing on what Comcast will do. They can see you’ve done a speed test on their site, it’s recorded, it’s attached to your account every time you do one. A Netflix speed test isn’t a good barometer of speeds either

Frequent Visitor

 • 

6 Messages

7 m ago

I agree with that as well, but how come ANY other website/download doesn't get me more than 20-27mbps?

My billing still shows my old plan - when I open my account and check billing - it says it's old plan.

my new plan shows in the account - xfinity.com/myplan

I think I might be stuck in limbo...

my automatic payment for my bill is supposed to be today

I changed plans on Friday and got confirmation on Saturday with the changes to the plan.

Frequent Visitor

 • 

6 Messages

7 m ago

Ok so looks like my router was due to be replaced. Although it supports up to 300mbps wireless connection, it got stuck somehow at no more than 30mbps
I replaced the router and now get constantly results on any speed tests - 100-116 mbps
It is actually more than what my plan is, and I can not complain about that!

New to the Community?

Start Here