ice-dwhitney's profile

New Poster


1 Message

Tue, Jan 19, 2021 3:00 PM

Unable to delete port forwarding rule

I have established three port forwarding rules for a computer on my network.


Since the port forwarding does not work whatsoever, I would like to delete these rules. Whether I use my browser or the Xfinity App (on my iPhone), I get this "error" when attempting to delete a rule:


We're Having Some Trouble

Please wait a few minutes and try again or restart your Gateway


I have tried restarting the Gateway, but still no joy.


What irks me the most is that one (of the three) rules is correct, but the Gateway is NOT forwarding packets to the identified system on the LAN. I know this for fact because I see no TCP traffic hitting my system while running WireShark.


Please fix the Gateway software. It's obvious that it is buggy.


P.S. If you suggest that I send a PM to some tech savvy individual, please provide crystal clear instructions on how to initiate a PM.



Official Employee


321 Messages

2 m ago

@ice-dwhitney, thanks for taking the time to reach out to us regarding your port forwarding concerns. I am very sorry for the delay in our response and truly appreciate all of your time and patience. I know that port forwarding can be very frustrating when you are having an issue getting this to function correctly. Can you follow the steps provided in the following link and let me know if you continue to have an issue? 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

Regular Visitor


4 Messages

1 m ago

Hello, I am also having this same issue for the last several weeks. I added a port forward back in December; however, the device has changed IP addresses and now I want to edit the ports and device. When I try to edit or delete the port forward without an associated device I get errors on the Xfi website. I cannot access the port forwards from the admin page. I have contacted Xfinity support and they had me reset my router/gateway, turn on/off advanced security, etc. nothing is working. Now I cannot use the ports which are in "limbo" with other devices. When will there be a fix for this as there are many users experiencing the same issues. I walked through the steps in the support article with no luck.



  • Port forwards without an associated device can’t be edited. If you want to use an existing port forward that doesn’t have an associated device, you’ll need to delete it, then create a new one by selecting Add Port Forward.
  • Advanced Security must be activated through the Xfinity app.

New to the Community?

Start Here