AlfieC's profile

New Poster


1 Message

Sat, Feb 13, 2021 12:00 AM

SB6141 with ASUS AC3200, getting "Your ISP's DHCP is not functioning properly" error

Hi. @ComcastChe and/or others,


I'm getting the exact same symptom as described in


I tried searching throught the net, I tried:

1. power cycle through modem and router both, in either sequence, no luck.

2. reset to factory settings on both modem and router, same error

3. upgraded the firmware on AC3200 and tried all three Normal/Aggressive/Continuous modes, made sure to reboot the router after each settings change.  same error

4. called Comcast to ask for the "device reprovision", they said it's already done so, still same error.

5. connect another Zyxel wireless router to the SB6141, get the same error

6. connect ethernet from SB6141 to my laptop, getting a public IP and able to connect.  But once switched connection to AC3200's WAN port, same error.


I'm running out of ideas.  It was working all fine in the morning and kids are watching youtube.  All of sudden the connection just all dropped.  And just not able to recover it since.......

Since the connection is working when connecting to the laptop directly, I doubt it would just magically come back?  Any help would be appreciated.


Thanks ahead.



No Responses!

New to the Community?

Start Here