Lisa719's profile

Frequent Visitor

 • 

11 Messages

Sat, Feb 22, 2020 6:00 PM

Closed

Paying for 500mbps Actual Speed is 50-95mbps

Since I dont even get a fraction of what is advertised. How do I downgrade my package to a lower speed?

Lisa719

Frequent Visitor

 • 

11 Messages

2 y ago

I dont get half of the speed they advertise. I will be downgrading when my package is up to the actual speed I am getting vs the speed they claim you get.

CCAndrew

Gold Problem Solver

 • 

25.9K Messages

2 y ago

Does whatever you’re testing on/with even have the ability to go over 100?. Is it Wi-Fi or hardwired connection? Would rather try to fix or drop your bill?
cxrider

Contributor

 • 

89 Messages

2 y ago

95 Mb/s is about what I would expect out of a windows box connected at 100Mb/s.    Have you verified that the problem is not your computer?    What is your reported link speed?

Lisa719

Frequent Visitor

 • 

11 Messages

2 y ago

I tested using Xfinitys own tool. And several others....all had a peak about 95mbps. Not even a fraction of the 500 I am paying for.


@CCAndrew wrote:
Does whatever you’re testing on/with even have the ability to go over 100?. Is it Wi-Fi or hardwired connection? Would rather try to fix or drop your bill?

 

Lisa719

Frequent Visitor

 • 

11 Messages

2 y ago

Its not my computer. I had Time Warner in California and got 225mbps with this same box. I am using the Xfinity Provided Router.....are their routers the problem maybe?

cxrider

Contributor

 • 

89 Messages

2 y ago

It *could* be your computer and here's why.     Gigabit network interfaces negotiate the speed they actually use.   Just because you have a 1 Gb interface does not mean it runs at 1 Gb and only 1 Gb.   Part of the protocol for link negoitation is to agree on a speed between switch and computer.   Those speeds can be 1000 Mb (1Gb), 100 Mb, and 10Mb.     The protocol says to try the fastest and if that fails,  the next fastest, and if that fails the next, etc., etc., etc, until a speed is established, *if* it can be established at all.     If the connection is established at 100 Mb then that's the speed used until the link is forced to negotiate speed again.     You may force link negotiate by rebooting the computer, rebooting the switch/router, rebooting both, or unplugging the ethernet cable for a few seconds then plugging it back in.     Either side of the connection is sufficent and it only needs to be long enough for the switch/router to determine link has dropped between the two.

 

You should be able to navigate to some window in your Windoze operating system and determine your link speed.   You will need to google how to do it because Micro$oft doesn't believe in designing a consistent interface between releases meaning that each release has a slightly different way of accessing the same data.    This url may help you.

 

Your observed data is consistent with a 100 Mb link.      100 Mb is the theorectical speed and in practice it is not observed.    Your modem can be running at 500 Mb service but if you throttle your connection to 100 Mb, that's all you'll ever measure.  

 

It is highly unlikely the issue is with your router.   The most probable cause for the observed data is a link running 100Mb.   

New to the Community?

Start Here