pooy's profile

Regular Visitor


2 Messages

Mon, Jun 8, 2020 5:00 PM

New modem (Arris T25) won't activate through webpage or support helpline

I recently changed plans and had to upgrade to a newer modem to get the rated speeds. When looking around for a replacement I found one that seemed to be a good fit, but noted that the highest rated review on Amazon talked about how difficult it was to activate (specifically with comcast/xfinity). This particular modem comes with two Mac addresses, and one seems to be for a phone line. The support person asked for my mac id, and I tried to ensure they used the correct one, but after about 30 minutes of trying it never worked. The support person directed me to the manufacturer of the modem which is laughably useless considering it's brand new.

I went back to the activation page, which I forgot to mention-- I tried earlier but it couldn't detect the modem and pointed me to the support line-- and all of a sudden it seemed to "work", telling me the connection should be online in 30 minutes. But obviously I wouldn't be here if it was.

I went the "my devices" page and my new MODEM is listed as a wireless gateway (which it isn't), and also the serial number is my mac address for some reason, so something seems very messed up here and any help would be greatly appreciated





86.6K Messages

1 y ago

Give this automated device activation line a shot: 1-855-652-3446. Even if the automation fails, you then get connected to an advanced repair representative rather than a tier 1 phone rep. Good luck !!!

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New to the Community?

Start Here