U

Visitor

 • 

2 Messages

Tue, Sep 28, 2021 9:44 PM

My DHCP connection started failing today

I’ve been an Xfinity internet user for years, with no change to my settings (modem or router) for years.  In the middle of the day today the wireless network stopped working.  Then, after some reboots of the modem and router, all connections stopped working.  I checked my router’s config page and it says “Your ISP’s DHCP does not function properly”.  Can you help me?

Accepted Solution

Visitor

 • 

2 Messages

1 m ago

Yes, I have an ASUS router, and what I found in my searches was suggestions to contact Xfinity.  I did that, and the person I talked to sent a bunch of refresh messages to my cable modem and it eventually started working.  

So, in summary, if you run into this situation, and have an ASUS router, contact Xfinity and they can resolve it.  Note that I had already done a bunch of troubleshooting — rebooting modem and router, connecting directly to the modem (wired, which worked), upgrading the router firmware, etc. — and the Xfinity agent accepted that and picked up from where I was.  It was fixed relatively quickly.  Good experience.

andyross

Gold Problem Solver

 • 

7.1K Messages

1 m ago

Do you have an ASUS router? This is a known issue with them. There are multiple posts about it. A Google search should find several possible solutions.

jlavaseur

Problem Solver

 • 

631 Messages

1 m ago

I have a asus router, go to your routers admin page, if that’s the problem there will be a link to correct it, couple clicks and your good..

New to the Community?

Start Here