Lkpolo's profile

Contributor

 • 

447 Messages

Friday, February 9th, 2024 11:44 PM

Internet

The internet is so bad in my area, my router has been changed twice, a camera was changed out, multiple outages, 2 of the X2 cameras take turns disconnecting, and Find My at one point told me that my MacBook Pro was in Katy, TX. I live in Western Pennsylvania. After I rebooted my current router Find My now shows my MacBook Pro with me at my home. It takes way too long for Find My to locate all  the devices in our house. I’ve had three tech appointments in the last 12 days and we still can’t keep a stable connection for 24 hours. If a tech reads this please get some help to us. 

Official Employee

 • 

1.3K Messages

18 days ago

Hi, @Lkpolo. Thank you for reaching out. I hope you are doing well today. I understand you've had an array of issues with your services, which I'm sure has been very frustrating. I rely on my network as well, and I understand what a headache this can be. Especially after having a few visits already. 
I'll be glad to help provide any insights regarding the next best steps. When was the last time a tech was out to the home? Have you had a chance to inspect your power levels? Can you also let me know any troubleshooting you've done so far? 

Contributor

 • 

447 Messages

@XfinityVianney​ actually, I guess I was wrong. Again today three of four cameras are blinking orange and won’t connect.  I’ve used the xfinity app twice to reboot the router and unplugged it twice. I’ve also unplugged the three cameras that won’t stay connected and plugged in again. I still think there are issues outside of our home that are causing weak signals on my road. If you can get a crew sent out to fix the issue, it would be appreciated. Thank you 

Official Employee

 • 

1.2K Messages

Thank you for providing that insight, @Lkpolo. Let me pull up your account and see what we can do to get someone out there.

 

If you could send our team a direct message with your full name, the name listed on the account (if different), and the service address associated with your account, I'd be more than happy to look into this for you.

 

To send a Direct Message, please click on the “Direct Message” icon in the top-right corner of the screen, next to the bell icon, click the "New message" (pencil and paper) icon, then type or select "Xfinity Support". Type your message in the text area near the bottom of the window and press Enter to send your message and initiate a live session.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Contributor

 • 

447 Messages

After four tech visits, the tech that was here called his supervisor who is on the same node as our home checked the service and found that there are issues. My camera 4 was replaced again. All services, routers and cameras have been working since then. We even had a brief power failure a couple days later and the router and all cameras connected right away. They are now aware that there is an issue that is not inside my home that needs worked on. I have a cell number of a supervisor to call if it happens again. Hoping it will work for a while. Thank you 

Contributor

 • 

447 Messages

18 days ago

It took a couple of days before all services started working well.  Originally we had an XB6 router, then an XB8 was installed after a power failure. That didn’t work well so an XB7 was installed. I guess firmware updated as it was blinking off and on for a couple days along with two of the cameras. Work may have been done a block or so away to separate a node into two nodes. My location services one all Apple Devices said the devices were 1789 miles away in Katy,TX . That was fixed by shutting off location services and turning on again on all Apple Devices. Very frustrating experience and we were truly contemplating doing away with all Xfinity services in the process. I live in a rural area with lots of trees. Satellite dishes are not a good solution due to the trees. All services have been working for two days. Sadly, Xfinity needs to just bring the bucket trucks up her and work on nodes and other equipment to upgrade their infrastructure but that doesn’t seem to happen too often. It’s the same with West Penn Power. All the problems started with equipment damage of West Penn Power and then it was just a domino affect after that to XFINITY. One of the techs here for the Home Security equipment said he is down the road at another house every couple months that also has Home Security. 

Contributor

 • 

447 Messages

15 days ago

It looks like I’m still having issues with two of my four cameras. I’ve had techs out here three times and it looks like they got the cameras working but yesterday the same two cameras started blinking orange and won’t stay connected. I’ve tried contacting Home technical support but keep getting hung up on. Not sure what to do at this point. I really need help. I’m going to be gone all day tomorrow and not sure what is going to happen after that for availability as my husband has heart surgery and I need to see what’s going on in and outside of my house from the hospital. 

forum icon

New to the Community?

Start Here