M

Visitor

 • 

4 Messages

Tue, Apr 5, 2022 1:27 PM

Instagram Does Load on Wi-Fi

Why doesn't Instagram load when I'm connected to the Wi-Fi?

Official Employee

 • 

854 Messages

6 m ago

@Marcology_101 Thank you for reaching out to the Digital Care Team. I hate to hear this has been your experience. Is this happening on one or all devices in the home? Have you removed the application, then installed it again? 

Visitor

 • 

4 Messages

@XfinityHeather​ it's only with cellphones and tablets that are connected the Wi-Fi. My laptop is fine. 

Official Employee

 • 

854 Messages

@Marcology_101 Thank you. On a Wi-Fi connected device, please forget the network name, restart the device, then reconnect. Are you able to access it now? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

5 m ago

I'm having the exact same problem and the suggested solution didn't work for me. I'm on a phone running Android 11. Instagram doesn't work on our home network, but does on cellular data. (Also works on our neighbor's ting network, but not on our Xfinity.) Clearing the app's memory and cache gets me a one time use, but the second time I use the app, it's back to the above-mentioned issue. It's super frustrating!

Visitor

 • 

1 Message

4 m ago

I too have been having this problem since April. Affects only my android devices running Android 11 and 12 while on my home network through Xfinity. But posts, stories and the feed do load properly on an older phone running Android 10. My laptop browsers and iOS devices don't have this loading issue. I've uninstalled and reinstalled Instagram multiple times and with no improvement. Additionally, Instagram on the Android 11 and 12 devices do load properly while connecting to neighboring "xfinitywifi" and "XFINITY" WiFi Hotspots. I own my own modem which is a Motorola MG7700 with built-in AC1900 WiFi router.

(edited)

Visitor

 • 

4 Messages

4 m ago

I've realized it only happens when my Android is connected to the Wi-Fi. As long as I'm on TMobile 5g network, I'm good to go. So I know it's the Wi-Fi not the phone. 

Visitor

 • 

1 Message

4 m ago

I'm having the same issue on an android. It only happens on my xfinity wifi. Everywhere else no issues.  The fix did not work 

XfinityGina

Official Employee

 • 

638 Messages

Thank you for letting us know, @user_e3d60a. Reading through this thread, it sounds like many of the issues are only on mobile devices running Android. Have you or anyone else in this thread noticed it happening on any other kind of devices on your home network? And were you all able to access the Instagram app before? Was there a recent update or anything that preceded this? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

4 m ago

The fix didn't work for me either. And us8ng phone data isn't a fix. I'm guessing it's something in the default router settings, but I don't know what to do about it. I'm using the Xfinity router.

Visitor

 • 

4 Messages

3 m ago

Having the same exact issues for the last 2 months with android devices. Instagram works fine on windows laptop or ios devices.

I even added another router to see if Instagram will work fine and it did so definitely a problem with the xfinity router on Android devices.

Official Employee

 • 

203 Messages

Thank you for this information @user_3ebab4. When you added the second router, was it still connected to your home internet?

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

4 Messages

Yes it was still connected to the Xfinity Modem/Router XB7.

Official Employee

 • 

231 Messages

Thank you for being so patient. If I may ask, once you restarted the Xfinity router did you also restart the android devices? This can be helpful along with uninstalling and installing any apps which may not be working like Instagram. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

4 Messages

Yes I have had this issue since April i have tried everything at this point. Clearing app cache and data uninstalling and then reinstalling the app restarting my phone restarting the modem. It does not seem to work.

Everything works exactly fine as soon as I connect to the second router or use my cellular data.

Official Employee

 • 

231 Messages

I appreciate all the steps you have taken so far to find a resolution. Just curious, have you tried contacting the manufacture of the Android device you having the issues on? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

3 m ago

I too am having instagram problems with a new s22FE phone.  Uninstalled the app, cleared cache on instagram and Data, Reset network settings on the phone, Even Factory reset the modem/router from xfinity(Technicolor brand).   I am about to venture into a 3rd party router and return the rental .  My S20FE picks up instagram now and so far is working but the S22Fe phone still wont on home wifi.  Public Wifi and Mobile network it works very fast but at home it behaves like a dial up connection when trying to view photos of followers.  Definitely something with the Technicolor Modem.  I am getting 340 mbps downloads wired and over 200 wireless throughout the house.  Ipad instagram comes in fine.  Just mobile phone.

Official Employee

 • 

866 Messages

Hi, @user_e83802. If it's just the one device having issues, have you tried removing the app then downloading it again? After that's done, restart the phone. If your Wi-Fi is working otherwise, I wouldn't jump to swapping out the modem as a step. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

3 Messages

2 m ago

Xfinity it’s not our DEVICES having ISSUES. Our mobile devices weather it be android or iPhone are having this issue. I didn’t have this issue until I had to change my modem. I got a newer model modem and ONLY my mobile devices won’t work properly. It’s connected to the WiFi and SOME apps do work but a minority of my apps won’t load while on WiFi and the couple that do load take forever to load videos or even scrolling through feed it won’t load. This is my second major issue with Xfinity, which I’ve just recently got a new modem because Xfinity TOLD me they couldn’t help me, and again Xfinity agents aren’t figuring out the issues to help us resolve. 

Official Employee

 • 

657 Messages

Hello, @BebsBear. I would like to ensure we get a ticket opened and further troubleshoot this with you to ensure we figure out what's happening with Instagram when on our home Wi-Fi services. Please send us a Direct Message with your first and last name. The message icon is located at the top right of the Community Forum page, clicking on the message icon will allow you to initiate a chat conversation with us directly. Please ensure you are sending your message to our 'Xfinity Support' handle. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

2 Messages

I'm having the same problem. The app and device behave totally normally on any other wifi. It's when I'm on my home Xfinity wifi that nothing loads. 

Visitor

 • 

2 Messages

@user_21cb84​ it also seems to have something to do with 5ghz wifi. Switching to 2.4 ghz bands seems to work. 

forum icon

New to the Community?

Start Here