Zone99's profile

Contributor

 • 

48 Messages

Sat, Jan 2, 2021 9:00 AM

How do you change the default IP of the XFi gateway or turn it into a true bridge??

When I upgraded to the XFi gateway, I found that it was basically requiring me to use it as the default gateway.   Prior to that I had been using my Netgear Nighthawk R8000 router flawlessly for DHCP, wireless and LAN connectivity on my network.  

 

However, the XFi gateway INSISTS on being 192.168.1.1 and will not allow you to change that last octet number.  Fine, I left it alone and changed my Netgear router to .2 and set it up as an AP.

 

The recent data cap changes mean that I need to use QoS on my network to see which devices are using up data.  Despite Xfinitiy's assurrances, I appear to be one of those that are close to the 5% that are likely to be above the data cap.  Different topic, not sure why.  Our house usage isn't all that different from others.

 

Regardless, I wanted to turn the XFi gateway back into Bridge mode, set my Netgear to be the default gateway and have QoS features turned on.  

 

It seems, though, even though I've read that Bridge mode turns OFF that IP, it's not possible to do this.  I turn on Bridge mode and the router status shows it as 192.168.1.1 and the entire section is not editable.   This, obviously, conflicts with my router.

 

According to: https://www.xfinity.com/support/articles/wireless-gateway-enable-disable-bridge-mode, if I've enabled bridge mode and I want to change it back, I have to connect to the gateway via an ethernet cable.  

 

How do I know it's not working? Because after setting bridge mode, I'm able to connect to 192.168.1.1 again via a web browser.

 

Any help here?  

 

BTW: it's really bogus to enable a data cap and not allow for QoS features to montior usage by device.  

Responses

jlavaseur

Valued Contributor

 • 

436 Messages

6 m ago

Bridge mode makes the gateway act as a modem, the modem should be the default gateway, that doesn't shut off that 192.168.1.1, but if you route all your traffic thru your router wouldn't you get the same results? Just a thought

EG

Expert

 • 

87.2K Messages

6 m ago

FWIW. Straight cable modems or combo gateway devices that are in bridge mode are layer 2 bridges. They don't do DHCP, so they don't assign private / LAN IP addresses such as 192.x.x.x or 10.x.x.x. They bridge the public / WAN IP address (such 68.x.x.x) that is assigned by the Comcast system DHCP server to the device that is connected to the LAN side of the modem (such as a router or a computer). They don't do routing or NAT translation either.

Zone99

Contributor

 • 

48 Messages

6 m ago

@EG 

 

I totally get that.  As just a modem, it should be a layer 2 device and no IP address assigned.  

 

However, when I enable bridge mode on the modem and reboot, I can no longer reach my Netgear router on which I turned OFF AP mode and has a specifically assigned IP.

 

When I then try to go to 192.168.1.1, the IP address of the XFi modem when it's NOT in bridge mode, it opens up the XFi gateway page and I'm back on the XFi gateway.  It's very, very confusing.

 

Any other suggestions are greatly appreciated.

Zone99

Contributor

 • 

48 Messages

6 m ago

@jlavaseur In bridge mode, the modem shouldn't have an IP address and doesn't act as a gateway.   My netgear router, as the device that's hooked into the XFi LAN port, should now be the DHCP server/gateway.   I should be able to ping it's address and connect to it's management port but I can't.

 

In this setup, the modem has no IP....but it does....

jlavaseur

Valued Contributor

 • 

436 Messages

6 m ago

Sorry if this answer is too basic but, my understanding is when you put your comcast gateway into bridge mode it disables the wifi, you say you you turned the the AP on your router off,  so unless your connected to your router via ethernet cable, i dont see how you can reach it, just a thought

Zone99

Contributor

 • 

48 Messages

6 m ago

@jlavaseur Great question.  I could have been more clear on that detail.  I'm doing my administration from a desktop connected to my router via Ethernet.  What's really odd is I can't connect to the router when I'm in this mode (x.x.x.2).   Like I said, it still connects me to the (what is now) a cable modem.....

jlavaseur

Valued Contributor

 • 

436 Messages

6 m ago

Ok here is a long shot, I was watching a network video, and be point they made was, you have to have some space between the 10.0.0.1 and the first dhcp address, on my gateway, it goes from the gateway address  10.0.0.1 to 10.0.0.2 the first dhcp address, so I am thinking whatever address you assigned as your router static address it probably fell in the dhcp range, so maybe it corrupted something in your router,, if it's the same as my setup, I just set the first dhcp address as something like 10.0..0.10 on my gateway, so I had room to assign static ips, yours could be 192.168.1.10 as the first dhcp address, so your have space to work with when you assigned your router it's static ip, just a thought as it's very odd you can't access your routers ip connected by Ethernet 

New to the Community?

Start Here