A

Tuesday, September 19th, 2023 10:10 AM

Closed

Help! My WiFi Isn't Secure

The minute I got my gateway up and running, I've been getting a bunch of notifications from the Xfinity app of phones and computers I don't recognize connecting to my WiFi. I created a password that seems complicated enough. My network is listed as strong and secure, it has the lock logo, so it's not like my password didn't register.

I don't understand how this could be happening. Any suggestions?

Thanks,

Adam

Official Employee

 • 

1.2K Messages

9 months ago

@addieBl Thank you for reaching out via our Xfinity Forums. Those items are typically Smart Home Devices. You can test this by blocking them and checking to see if those devices are functioning. 

 

Those things are typically Smart Home / IoT devices and your own gateway device. What you can do if you like for a test is to block them one by one and see what devices on your home network no longer function. You can use the xFi app to manage individual devices. This guide will tell you more about pausing/unpausing devices and will walk you through the steps: https://www.xfinity.com/support/articles/personalize-customize-hnetwork-xfi

 

I hope this helps, but if you have further questions, please don't hesitate to ask. 

Problem Solver

 • 

1.5K Messages

9 months ago

More than likely you don't have an MoCA point of entry filter installed, and your neighbors are intentionally or unintentionally connecting to your gateway over the coax.  MoCA is Ethernet over coax.  This is especially common in apartment buildings.  Xfinity MoCA enables itself if a device is present and has zero security in their implementation.

For around $10 bucks, you can buy one from Amazon or Walmart.  If you have no other MoCA devices yourself (like a cable TV box), you can screw it inline right to the back of your gateway.  If you do, then it should go on the coax where your service enters your residence.  Search for "MoCA PoE filter" to find one, or you can get one at an Xfinity store if there is one by you.

"Pause" -- well that's kind of silly.  It's a security breach problem, also a bandwidth and data use issue, and many devices used randomized MAC addresses these days, so that's not going to help.

1 Message

9 months ago

I'm having the same issue. It's a new install in an apartment and I've followed the steps to update the SSID and password. The Wifi SSID has a "No Security" message (and no padlock icon) on the phones and tablets, with no prompt to enter a password. They successfully connect and can browse. I've set the password in the app and also directly on the router plus tried the 2 available security protocols but to no avail. I haven't had this issue setting up other providers and is the first time using Xfinity and first time at this address. I also tried to contact support and the chat was of no assistance.....

Any suggestions welcomed.

forum icon

New to the Community?

Start Here