user_pfam79's profile

New Poster

 • 

7 Messages

Monday, July 8th, 2024 11:40 PM

Gigabit Extra Plan Not Getting Advertised Upload Speeds of 200+ Mbps

Live in CO Springs, CO, and I have the Gigabit extra plan. Lately I haven't been getting the advertised upload speeds I'm supposed to get. My download speeds have been fine, get about 1350mpbs download on my pc/phone through wifi6e/wired but my upload has been stuck around 45-60mbps. I was previously getting about 240mbps upload and i'm not sure what changed. I have checked all my equipment, reset my modem and separate router I use, also upgraded to an XB8 gateway from xfinity to replace the XB7. Also had COMCAST reps reprovision my gateway a couple of times but that didn't do anything. Anyone else having problems lately not getting good speeds? I run a plex server and not getting good upload speeds is causing me issues. 

Official Employee

 • 

1K Messages

14 days ago

Hello @user_pfam79, Thanks so much for taking a moment out of your day to leave a post on our community forum. If you could send our team a direct message with your full name, the name listed on the account (if different), and the service address associated with your account, I'd be more than happy to look into this for you. To send a Direct Message, please click on the chat icon in the top-right corner of the screen, next to the bell icon, and then type or select "Xfinity Support" to initiate a direct message.

Expert

 • 

104.8K Messages

13 days ago

@user_pfam79 @XfinityChelseaB 

Please circle back here and post any possible solutions for the issue here in these open public forums so that all readers here may benefit from the exchange / info. This is in keeping with the spirit for which these public help forums were originally intended. Thank you.

Visitor

 • 

10 Messages

12 days ago

Yes, I am having the same issue here in the Chicago area. I currently have 2 locations on my Xfinity account. At location #1 I have 1200/200 internet, with speeds exceeding those numbers. At location #2 I also have 1200/200 internet, with download speeds exceeding 1200. However, my upload speeds are capped (throttled) at 40. Between September 22, 2023 and November 15, 2023 my upload speeds at location #2 were averaging 240 Mbps. Since November 15, 2023 however upload speeds at location #2 have been capped at 40 Mbps. After numerous calls to Xfinity Tech Support over several months, I was told to update my modem from XB7 to XB8 to no avail, and numerous tests were run, my modem reprovisioned, and a tech visit yielded no issues, but still to this day my uploads max out at 40 Mbps.

Visitor

 • 

10 Messages

10 days ago

My Xfinity Internet Upload issue was finally resolved tonight! Thanks to the Xfinity Techs; Xfinity Benjamin M, Xfinity Amanda B, and Xfinity Marty R, for resolving this 8-month long issue.

Resolution: After stating my issue here in a new thread, Xfinity replied and asked me to send my info to them via direct message. They then tried to re-provision the modem, and then finally, The bootfile to the Gateway was updated to the correct one, finally giving me the faster upload speeds. I'm back averaging 236 Mbps for uploads!

forum icon

New to the Community?

Start Here