greenware's profile

Regular Visitor

 • 

3 Messages

Sun, Dec 6, 2020 2:00 PM

FTP Stopped working

With upgrade to xfi modem, command line FTP batch file stopped working.  Signs in the to server but "put" file hangs....

 

Batch file worked for 15 years before upgrade.??

 

 

Responses

strega7

Regular Contributor

 • 

393 Messages

8 m ago

Are you running in passive mode?  In non-passive mode (default), the server makes a connection back to you to transfer the file.  (Which typically-configured consumer routers will just ignore.)

greenware

Regular Visitor

 • 

3 Messages

8 m ago

I don't think FTP.exe does passive.. Things worked before Comcast Upgrade but not after.

jlavaseur

Problem Solver

 • 

579 Messages

8 m ago

Maybe try out FileZilla, it's a free ftp/sftp client/server that it very good, it has a lot of configurable options, it has a great user interface 

greenware

Regular Visitor

 • 

3 Messages

8 m ago

No command line optiones for filezilla....

 

Point is FTP worked..Modem upgrade FTP doesn't work. Let's fix it...

EG

Expert

 • 

88.1K Messages

8 m ago

Have you forwarded the proper ports for your FTP setup ?

 

You can also try disabling the Xfi Advanced Security feature as a work-around for now and see. It's buggy ! And there is currently no way for an end-user to be able to whitelist anything;


To disable the Advanced Security feature in xFi, select the Account icon from the top-left corner of the Overview tab on the xFi app and then select xFi Advanced Security. From here, select Disable under xFi Advanced Security and follow the on-screen prompts.


https://www.xfinity.com/support/articles/xfinity-xfi-faqs

strega7

Regular Contributor

 • 

393 Messages

8 m ago

Here's a thread I googled up:

 

https://stackoverflow.com/questions/18643542/how-to-use-passive-ftp-mode-in-windows-command-prompt

 

Apparently, Explorer has supported passive mode for many years but ftp.exe never got it.

 

From the thread: " The Windows FTP command-line client (ftp.exe) does not support the passive mode, on any version of Windows. It makes it pretty useless nowadays due to ubiquitous firewalls and NATs."

 

In addition, the people on that thread show a bunch of ways to get this working, such as converting Windows FTP scripts to WinSCP scripts, or psftp, or the "Windows Subsystem for Linux" (WSL).

 

WSL link:

 

https://docs.microsoft.com/en-us/windows/wsl/about

 

While not discussed in the thread, perhaps you could get around the lack of passive with some port forwards. Or, I suppose a more "generally permissive" firewall/router.  (I see that EG suggested this while I was typing.)

 

I remember running into this same issue.  In my case it was in the 90s when I switched from dial-up modems to DSL and for the first time I had a firewall appliance between me and the internet.  At that time, I learned about passive mode and have used it ever since.  This seemed easier and safer to me than punching holes in firewalls. (I currently use WinSCP.)

Visitor

 • 

5 Messages

1 m ago

I have exact same issue. Suddenly, my ftp puts won't connect to the the host server.

Visitor

 • 

5 Messages

1 m ago

Same issue here. Suddenly my FTP uploads won't connect. Trying all sorts of things, but then thought "the new Xfi modem is only different thing".

New to the Community?

Start Here