smth_snail's profile

New Poster

 • 

2 Messages

Fri, Dec 4, 2020 7:00 AM

Extremely high latency

Hello, I'm new to this forum, and I came because our Xfinity connection has extremely high latency, at random times but on average at least 15 hours per day. Customer service on the phone has not been helpful at all. Like many nowadays, the living of my entire family relies on the Internet due to working and schooling at home. We already replaced both our wireless router and modem, but the frustration persisted. So any help will be greatly appreciated.

 

Here is a speed test result

badInternet.jpg

and below is a ping experiment:

 

ping -t www.comcast.net

Pinging e7010.dscg.akamaiedge.net [23.59.120.89] with 32 bytes of data:
Reply from 23.59.120.89: bytes=32 time=1321ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1057ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1200ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1039ms TTL=59
Reply from 23.59.120.89: bytes=32 time=976ms TTL=59
Reply from 23.59.120.89: bytes=32 time=997ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1106ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1139ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1192ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1131ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1266ms TTL=59
Reply from 23.59.120.89: bytes=32 time=657ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1019ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1262ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1089ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1173ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1174ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1119ms TTL=59
Reply from 23.59.120.89: bytes=32 time=764ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1009ms TTL=59
Reply from 23.59.120.89: bytes=32 time=1109ms TTL=59

Responses

EG

Expert

 • 

87.1K Messages

7 m ago

Is this with a WiFi connection ? If so, for a test, does a computer / device hardwired directly to the router / gateway device with an ethernet cable have the same problem ?


With this test, we are trying to isolate this from being either a WiFi-only problem or a problem with the general connection to the Comcast system which would of course affect both. It's a good first step of troubleshooting before we proceed any further.

New to the Community?

Start Here