H

Visitor

 • 

1 Message

Fri, Jun 18, 2021 8:49 PM

ethernet capped at 10mbps

I have a service speed of 400mbps, network card is Realtek PCe GbE Family Controller, and cable is cat6. I have changed my link speed to 1 gigabit/full. However, a speed test with the ethernet never gets about 9mbps (wifi is between 60-140mbps). Checking "view network settings" shows the speed still at 10mbps, despite having changed it in the advanced properties settings. I have gone through every forum related to my PC and/or cable being the issue, including updating the network drive, deleting and reinstalling it, checked the cable (it's brand new), etc. and nothing has fixed the issue. Could there be a setting on the router side of things? I have also tried lowering the link speed to 100mbps/full; changed nothing. Any help would be greatly appreciated. 

Responses

jlavaseur

Problem Solver

 • 

579 Messages

1 m ago

Try getting the drivers off the Realtek website, it states on there the plug wnd play Microsoft drivers don’t work with that card, I had problems until I updated to their drivers

XfinityBrie

Official Employee

 • 

268 Messages

1 m ago

Hey there @hanzb! Thanks for joining us in the Xfinity Support Forums. It looks like you've done a good chunk of troubleshooting on your own already, out of curiosity, have you also tried that ethernet cable directly to the modem (bypassing the router entirely)?

 

jlavaseur brought up a good point as well about getting the drivers direct from the Realtek website.

New to the Community?

Start Here