M

Visitor

 • 

3 Messages

Fri, Sep 24, 2021 7:31 AM

Epson printers issue with new Xfinity router XB7 Solved!

This is not a question, but an answer to many questions I saw on this topic. As I spend hours figuring this out, I though it maybe helpful to someone else.

I have Epson WorkForce 845 and when I setup my home with XB7, it didn't connect to the network. I tried all suggestions I could find in this forum but none worked. This is how I finally got it working:

  1. Install Epsonnet config tool from Epson website

  2. Refresh until you see your printer (even in half connected mode, the software will find the printer, but make sure the wifi is turned on for both devices)

  3. Click on your printer to open configuration
  4. click Basic Wireless

  5. Change to ad hoc and accept the warning

  6. change back to infrastructure which now let you choose wireless mode.

  7. Choose 802.11b/g (I tried both b alone and b/g/n but none of those worked, however b/g worked).

  8. Now choose your SSID and enter your password and transmit it to the printer.

  9. Vola.

Hope this save time for someone.

Visitor

 • 

1 Message

3 d ago

Which Epsonnet config tool did you use?

Visitor

 • 

3 Messages

@user_f8bd5b https://download.epson-biz.com/modules/pos/index.php?page=single_soft&cid=6047 

New to the Community?

Start Here