Glaxalg's profile

Regular Visitor

 • 

4 Messages

Sat, Jan 9, 2021 11:00 AM

Assigning static IP to a device

Hello,

 

I'm trying to assign static IP to one of my devices but it fails with the error "Failure! Please check your inputs."

 

What am I doing wrong? I was able to assign static IP before (about a year ago)

 

Responses

unixfreak

Frequent Visitor

 • 

16 Messages

5 m ago

What's the device /OS?

Regular Visitor

 • 

4 Messages

5 m ago

I tried many devices:

- Laptop mac OS (BigSur)

- Printer Brother 

- Sonoff smart WIFI switch 

- ...

 

BTW, Factory reset didn't help

kentshaw

Most Valued Poster

 • 

909 Messages

5 m ago

Some routers have a set range for DHCP IP addresses.  Are you trying to set static addresses within that range? Are you trying to assign an IP address that is already being used by another device?  I like to run Belarc Advisor (free download) and it will show all devices on your network including their MAC address and IP address.

jlavaseur

Valued Contributor

 • 

432 Messages

5 m ago

Exactly, on my Xb7 it went from the gateway address 10.0.0.1 to the first dhcp address 10.0.0.2, I just changed it to 10.0.0.15 so I had room to work  with

jlavaseur

Valued Contributor

 • 

432 Messages

5 m ago

It can't be in the same range as the dhcp assigned ip addresses, it can only be lower or higher then the dhcp ip range

Regular Visitor

 • 

4 Messages

5 m ago

My DHCP range is specified as:

  • Subnet mask 255.255.0.0
  • DHCP beginning address 10.0.0.2
  • DHCP ending address 10.0.0.253

When I try to assign reserved IP for a device like 10.0.0.238 I get the error "Failure! Please check your inputs." In case that I assign IP out of DHCP range like 10.0.1.238, I get the error "Reserved IP Address is not in valid range: 10.0.0.2 ~ 10.0.0.253"

Regular Visitor

 • 

4 Messages

5 m ago

I was trying to assign static IP of the same value that DHCP assigned to a device. So, the IP is in the network range and the IP is not used by any other devices 

jlavaseur

Valued Contributor

 • 

432 Messages

5 m ago

Exactly, because 10.0.0.238 falls in your dhcp range, a static ip can't be assigned a IP in the your dhcp range, the way your dhcp is configured try a ip over 10.0.0.253, you might have to configure your dhcp server to use for example, 10.0.0.15 to 10.0.0.253, then you could assign a static ip anywhere between 10.0.0.2 and 10.0.0.14

kentshaw

Most Valued Poster

 • 

909 Messages

5 m ago

Set your DHCP to a narrower range.  You will have to reboot the router so that IP addresses can be reassigned after the change.  Then add the static address outside that range.

New Poster

 • 

1 Message

3 m ago

He's Not talking about setting a static, he's talking about reserving an IP through DHCP.  Reserving uses the MAC address of the device to assign the same IP everytime it connects, it is a way to make a device work the same way as if it were static it's actually a better way to do it for most applications.

jlavaseur

Valued Contributor

 • 

432 Messages

3 m ago

ok when you go to set it, you Have to something in the comments box, anything will do, then it will work

New Poster

 • 

1 Message

3 m ago

Not sure if this will help you, but I just managed to get my printer to accept a Reserved IP.  I did have words in the comment and got the error message.  I changed the comment to one word, and it accepted the change and reserved the IP;  shows up as Reserved IP under the DHCP/Reserved IP column finally.  Hoping that will stop the printer from disconnected constantly...

Visitor

 • 

1 Message

3 m ago

I can confirm that all you need to do is add a one word comment in the comment box. I was getting this failure as well and VPUNITAS1's comment is correct.

Visitor

 • 

1 Message

3 m ago

@VPUNITAS1 @sdfhgsdf : you just posted this literally four hours ago. I was hoping for the best, tried it, but doesn't work for me (though it seems EXACTLY like the kind of stupid thing Comcast routers would have built in).

Did you have to reboot the router (either hard reset or through the system)? Or is there some other step I'm missing? I'm certain that I don't have anything else assigned. It's within the 10.0.02-10.0.025X (can't remember high #) reserved addresses, which has always been, to my understanding, the way to do this (tho some ppl above seem to imply the contrary).

Thanks!

Thanks! 

Visitor

 • 

1 Message

3 m ago

Yep, a single-word comment is the trick. 0 words fails, 2+ words fail. 1 word is what's required. That is silly and utterly frustrating that they don't include that pivotal fact in the error message.

New to the Community?

Start Here