demillerusn's profile

New Poster


2 Messages

Sat, Oct 10, 2020 6:00 AM

Advanced Settings Inaccessible; DNS reservations

Before you read this long post - if you're looking for advanced XFI settings - go here:


There are many posts about Xfinitity XFI taking over advanced router settings, particularly port forwarding.  This was also coupled with setting a DNS reservation for me.

Some observations / problems / brute force (and by no means clean) solutions:


My Xfinity modem/router is Arris TG1682G


1 - I set a DNS reservation directly in the modem reservation page.  I made a mistake and added the incorrect MAC address.  Initially no problem, the reservation showed up under inactive devices.  Then when I realized the MAC was wrong, NO WAY TO REMOVE IT FROM THE LIST (not yelling - emphasizing!). Ultimately I had to take my Linksys router, clone the MAC address, plug the WAN port into the Xfinity router to activate the reservation, then pull it up from the list of active devices and edit it back to a DHCP reservation.  From there I was able to remove it from the list after unplugging the router and going into Xfinity XFI to remove the inactive device (not easy to find - but there under inactive devices when you select a device and go to the bottom).  No other method allowed me to remove it.  Couldn't change it, couldn't access it, couldn't add a new reservation with the same incorrect mac, nothing.  I didn't do a full factory reset because I didn't want to go back and start from scratch.  I  shouldn't have to just to remove a DNS reservation, right?!!  And the reservation never shows up on XFI management until it actually gets activated at least 1x from what I can gather.  Re-adding the correct reservation was impossible unless I just choose a different reserved IP and host name (ok - I'm bullheaded and a little OCD, I liked the reserve IP I initially chose!!).


2 -  Now it was time to add the correct DNS reservation.  I was still inside the modem/gateway admin settings - not online XFI management.  Multiple time-outs, lock-up, conflicting MAC reservation, conflicting IP reservation, 10 minute restarts (REALLY?  10 minutes?!!), even though the old reservation had been removed.  Somehow after about the third restart and multiple attempts the correct DNS reservation showed up properly even though it never went through the add reservation process cleanly.  Not to mention why does it take 30 seconds or more each time I click on a setting for the page to refresh from the admin page?!!


3 - While going through this, I was also trying to set a port forward.  Ran into the issue well documented before, you have to go through the XFI page, it's not available on the modem/gateway admin page.  Initially ADVANCED SETTINGS was at the bottom of the gateway page (under MORE) as is also documented.


4 - after fixing the DNS reservation (an another 45 minutes figuring out how to get back into my Linksys routers admin page directly - not through the online management tool to change the cloned MAC and settings back to bridged mode).  ADVANCED SETTINGS was simply gone.  I went through several XFI pages, links, etc.  All took me back to the list of connected devices.  Some lists have the inactive devices at the bottom - other paths do not.  CONFUSING at best if you are trying to remove inactive devices as I mentioned above.  I finally figured out that anomoly, but still NO ADVANCED SETTINGS PAGE was linked anywhere!  Not under MORE, not at the bottom of the GATEWAY SETTINGS.  Simply gone.


5 - I tried deactivating ADVANCED SECURITY thinking that would set a mode that gave me the advanced settings back - NOPE, same result.  Finally after searching far and wide through this forum, at the bottom of some responses that point to where to locate the settings (which I had already searched multiple times for over an hour), I found the following link:


There it was, as long as I was logged in, it brought port forwarding right up.

actually goes one page back and gets you to all the XFI advanced settings.  The page I was able to browse to directly before.  Go back any further on that address and it's lost again.  There was no browsing back to ADVANCED SETTINGS.


I know the ultimate solution.  Get rid of the xfinity modem/router, get my own modem and router and manage it myself.  This is supposed to be customer friendly, not advanced routing.  Even so, hiding, blocking, removing access to advanced settings from the router admin page itself, or (and HOW this even happened I have no idea), removing advanced settings from the XFI management page, is just plain ridiculous!!






Accepted Solution




1.9K Messages

7 m ago

It’s still there on xFi but you had to look harder as they changed the navigation.

Connect > See Network and you will clearly see Advanced Settings in plain sight.

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster


2 Messages

7 m ago

There it is!!

Let's see how many other places they can find to hide it...



New to the Community?

Start Here