dhawan's profile

New Poster

 • 

3 Messages

Sat, May 16, 2020 2:00 PM

Achieving 600Mbps download speed with Arris SB6190 model

Hi, I purchased the 600Mbps plan and per Xfinity recommendation on compatible equipments, bought my own SB6190 cable modem.  When I tested my speed it's at 230Mbps only with my computer connected directly to the wired modem output. I called Arris ane they told me that my upstream channels need to increase from 4 to 8 and power levels needs to be increased. Xfinity tech support tells me that SB6190 does not support 600Mbps and need Docsis 3.1 model even though thier own wesbite saysSB6190 which is Docsis 3.0  works for 600. And it seems they don't have a way to increase power unless I buy thier modem. Seems really disingenious to me. Any ideas or suggestions? Am I the only one with this issue?

 

Responses

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

1 y ago

They’re both wrong, there’s only 4 upstream channels, some markets 3 some 5 but it’s not something that gets turned on or off. You May need a second opinion from Comcast and get your modem reprovisioned

New Poster

 • 

3 Messages

1 y ago

Thanks Andrew. So I was told they don't have access to my modem because it's not thier modem. So you do agree that I don't have to get Comcast's modem which is Docsis3.1 just to achieve thier committed 600Mbps speed?

 

CCAndrew

Diamond Problem Solver

 • 

25.9K Messages

1 y ago

I agree but during the pandemic it may be difficult to do anything about it because you have service and are online

New Poster

 • 

3 Messages

1 y ago

Thanks. Yes, makes sense.

 

New Poster

 • 

1 Message

1 y ago

Did you ever get this resolved? I have the same problem and was told the same thing. I ordered a DOCSIS 3.1 Modem and will let you know if it works.

New to the Community?

Start Here