U

Visitor

 • 

1 Message

Sunday, December 31st, 2023 5:30 PM

Xfinity stream not recognizing eero as home network

I have an Eero mesh WiFi network with my Xfinity internet. Everything works on the WiFi network except that I can't stream Xfinity TV channels on my Samsung TV or AppleTV because Xfinity thinks that I'm not on my home WiFi network. This began happening last week after it was working perfectly for months. I can’t get Xfinity to recognize that my Eero WiFi network is my home network. I’ve restarted both my xfinity modem and the eero system to no avail. I tried using Xfinity’s extremely frustrating “support” known as the “assistant” and my issue doesn’t fit into the 5 it knows how to fix so I am caught in an endless loop.  

interestingly, my phone streams fine on the same network. 

Official Employee

 • 

1K Messages

6 months ago

 

user_fa3f96, Thanks so much for reaching out to Xfinity Support. A few things to try would be first, unplug it from the power source for 15 seconds, then plug it back in. See if that resets things. If that doesn't work, make sure your firmware for your devices and your Eero are up to date. Another thing, try another device that is not using the Eero and see if it can connect. If you still need assistance, let us know. We are here to help. 

 

2 Messages

Hi - 

I have rebooted everything which did not help.  The AppleTV is on WiFi, but the TVs are on the wired network, which is the way I want it because the signal is stronger.  All devices say I can’t stream because I’m not on my home network, even though I am, both wired and wireless.  Again, everything was working perfectly in the exact same configuration for months until this bloc suddenly came up.  I had a similar issue with Netflix, but their verification software resolved the issue in about 30 seconds. 

2 Messages

@user_a5jgg5​ I’m not sure why I have a different user name on here - but I am the original poster 

Visitor

 • 

13 Messages

4 months ago

I have this exact same issue with my Roku 3810x on Eero 6+ from my owned Arris owned modem. The Roku connects to everything EXCEPT the Xfinity Streaming app. I've done all the reconnects/re-installs also. I have an open ticket ECM0006235342 and support can see my Roku connected; my Eero app shows Roku connected also with the same MAC address listed within settings/system on my Roku. The Xfinity support says my Roku MAC address does not match my router probably due to the Eero in between my modem and the Roku. Support says there are others complaining of same issue (not sure if its got Eero in common though). I await a solution but if misery loves company.......move over as I'm on the same bench. 

FYI error is TVAPP-00101..........maybe we need to move to 2.0 (btw my Roku is Ver 12.5.x updated 01/2024 and not sure when this last worked I'm afraid)

1 Message

3 months ago

I am having this same issue.  Did anyone get this resolved?

Visitor

 • 

13 Messages

@user_i3hfoq​ This issue has been resolved as of Friday; sorry I didnt post. I never discovered the exact issue but mostly in common with others is the Roku/Xfinity app. The eero umbrella network between my Arris modem and the Roku happened to be part of my network but most complaints were regarding the Roku/Xfinity app.

Problem solved anyway.......yippeeee

Official Employee

 • 

1.1K Messages

 

user_i3hfoq Hello! If you are still experiencing issues with this, please let us know.

 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick
forum icon

New to the Community?

Start Here