U

Visitor

 • 

1 Message

Thu, Apr 29, 2021 6:13 PM

Error TVAPP-00170 when signing in to Xfinity Stream with Microsoft Edge

In Microsoft Edge, when I try to go to https://www.xfinity.com/stream/ I see the normal "Now connecting to your entertainment experience" for a few seconds, then get the following:

Sorry, we've run into a problem.

The good news? We can take care of it right now. First, you'll need to sign out of your account.
When you sign back in it'll be fixed. Ready?

(Error TVAPP-00170)

Sign Out

The "Sign Out" is a button, which when clicked, signs out and leaves me at the home page from which I try to sign in again, which repeats the process with no change.

However, using the same login and password, I am able to log in using Firefox and/or Chrome.

I have no extensions installed in Microsoft Edge.

I've tried multiple things to attempt to resolve this. For example, completely resetting all Microsoft Edge settings, changing various networking settings in Edge, etc. Unfortunately, nothing appears to actually help.

From a more technical POV, what appears to fail is that the code in the page (from looking in the Edge dev console) does a POST to https://xtvapi.cloudtv.comcast.net/partner/device/provisionWeb/, but gets a 403 response and returns the following data:

{
    "reason": "Provisioning failed due to upstream service error.",
    "statusCode": 403,
    "statusSubCode": "303"
}

It tries to perform the POST twice and gets the same response each time.

Interestingly, when I do the same process in Firefox, that POST is made to https://xtvapi.cloudtv.comcast.net/partner/device/provision/ (note that the last component of the path is different than the POST made in Edge), and it succeeds.

I'd like to be able to watch videos using Microsoft Edge, but can't do so. It looks like this is an Xfinity Stream software problem, but I'm happy to change settings on my end, if that will resolve the issue.

Responses

JodieNJ

Contributor

 • 

193 Messages

5 m ago

I do not get an error message, but I haven't been able to access Xfinity Streaming through Microsoft Edge for more than a week now.  I just get the "Now connecting to your entertainment experience" message and it never connects.  I have been using Xfinity Streaming on Edge for years now.  I have a new Comcast router (the white one) and Edge has been updated recently by Microsoft.  What's going on?

Official Employee

 • 

453 Messages

5 m ago

Hello and thank you for reaching out to us here on our Xfinity Forums! I am truly sorry that you are running into this error message with Edge and would love to look into it further on our end. Please send us a private message with your name and service address to Xfinity Support by clicking the chat icon at the top right of the page.

Visitor

 • 

1 Message

2 m ago

Error TVAPP-00170

Cant sign in even after signing out and clearing my cache. 

Official Employee

 • 

202 Messages

Hello @anyuser1123! Have you attempted to uninstall the app and install it again to see if this works? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

New to the Community?

Start Here