MarkGriz's profile

New Poster

 • 

1 Message

Fri, Jul 5, 2019 7:00 PM

Xfinity Stream in Roku stopped working

Yesterday, I was unable to access the Xfinity live TV stream in my Roku. It has worked fine for several months and has stopped. I get a message after authentication that says “Sorry! Unfortunately we cannot support high speed data customers without a video subscription.” I have done a Roku reboot, deleted and reinstalled the app several times. Nothing works. Can someone help? A chat with Comcast proved ineffective.

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

Rustyben

Expert

 • 

24K Messages

2 y ago


@MarkGriz wrote:
Yesterday, I was unable to access the Xfinity live TV stream in my Roku. It has worked fine for several months and has stopped. I get a message after authentication that says “Sorry! Unfortunately we cannot support high speed data customers without a video subscription.” I have done a Roku reboot, deleted and reinstalled the app several times. Nothing works. Can someone help? A chat with Comcast proved ineffective.

did you turn in all of your X1 set top boxes?

Official Employee

 • 

2.8K Messages

2 y ago

Hello, MarkGriz! 

Thanks for reaching out to us for help with the stream app on Roku. 

I would love to help troubleshoot this issue with you. Have you already had the opportunity to check your base cable equipment to ensure it is connected or have you made any changes to your services lately? 

Official Employee

 • 

2.8K Messages

2 y ago

MarkGriz, as I have not heard back from you in some time, I have closed this thread to further comments. I hope you were able to get your Roku up and working again, but if you still need assistance, please feel free to start a new thread.

New to the Community?

Start Here