dwender5's profile

New Poster

 • 

2 Messages

Wed, Jan 6, 2021 2:00 PM

Xfinity Stream Beta Application

Until about 09:00 ET Wednesday 01/06, my Xfinity Stream Beta App was working fine on my 2 Roku TVs (TCL and Philips brands). Now when I access it, it just goes to a PURCHASED screen and showing only the items I previously purchased. I have no access to a LIVE TV channel menu. I need to know what is going on. If I receive no word and answers / solutions by Thursday 01/07 I will plan to notify the news media of this issue.

Responses

New Poster

 • 

2 Messages

4 m ago

Same exact thing happening here, noticed last night on roku, and just check on ipad...  no live tv or fav live tv.  

New Poster

 • 

2 Messages

4 m ago

Xfinity made a change on 01/06/2021 around 09:00 Eastern Time as my TVs on the App were both working well and now they don't. Calling Xfinity Support provided NO ANSWERS.

As of this writing, still NO response from Support and both TVs still do not have a working Xfinity Stream BETA Application.

Rustyben

Expert

 • 

24K Messages

4 m ago


@dwender5 wrote:

Until about 09:00 ET Wednesday 01/06, my Xfinity Stream Beta App was working fine on my 2 Roku TVs (TCL and Philips brands). Now when I access it, it just goes to a PURCHASED screen and showing only the items I previously purchased. I have no access to a LIVE TV channel menu. I need to know what is going on. If I receive no word and answers / solutions by Thursday 01/07 I will plan to notify the news media of this issue.


not a widespread issue. with your smart phone and using the stream app does it play normally? 

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

2 Messages

4 m ago

Yes works on phone but not ipad or roku(s).....they did till just around 6th...

Rustyben

Expert

 • 

24K Messages

4 m ago


@Macy118 wrote:

Yes works on phone but not ipad or roku(s).....they did till just around 6th...


unplug the gateway/modem for 5+ minutes. after restart did the roku devices start working?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

3 Messages

3 m ago

I'm sure they will jump right on it

New to the Community?

Start Here