rasmusrj's profile
rasmusrj
Expressive Exchange
Stamp of Approval
Conversation Starter

Frequent Visitor

 • 

15 Messages

Fri, Jul 17, 2020 11:00 AM

Xfinity Stream Beta app stuck on purchase screen

It seems a lot of people have had this problem for a while and that it has not been resolved.

 

For about a month the app has been stuck on purchase screen across several Samsung devices, making the app useless.

Reinstalling and removing tv from power outlet seems to do nothing.

When will this be resolved?

Responses

Regular Visitor

 • 

8 Messages

10 m ago

Any luck?

Rustyben

Expert

 • 

24K Messages

10 m ago


@Fco301 wrote:

Any luck?


i re-escalted. hopefully even with covid they they get to you shortly

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

1 Message

7 m ago

I am having the same issue. I have reinstalled, added an authorized user, logged in and out, and it's still loads to the purchase screen. I have access to the app on my phone and tablet. I have a Samsung SmartTV and it was working until a few month ago when I upgraded my internet service. What can be done?

New Poster

 • 

3 Messages

7 m ago

I am having the same issue, I have been following this post looking for an update.

New Poster

 • 

3 Messages

7 m ago

It appears there's no resolution to this issue. I see that you have escalated the issue however I see post back from 2019 with the very same issue. Could you please advise!!!

New Poster

 • 

1 Message

4 m ago

Hello, I found this thread because I am facing the same issue. Has there been any updates regarding this issue over the last half-year?

Samsung TV: QN55Q75FM

New Poster

 • 

2 Messages

3 m ago

It seems to be an issue with Samsung and Xfinity. This app works on other devices with the exception of Samsung! Was working fine this morning then Boom Goes the Dynamite!
Rustyben

Expert

 • 

24K Messages

3 m ago


@Notafanof wrote:
It seems to be an issue with Samsung and Xfinity. This app works on other devices with the exception of Samsung! Was working fine this morning then Boom Goes the Dynamite!

try this: power unplug for 3-5 minutes the gateway/modem. after restarts power unplug the TV and restart. working?

I am not a Comcast Employee.
I am a Customer Expert volunteering my time to help other customers here in the Forums.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

2 Messages

3 m ago

I figured out the problem. I have two accounts and realized that it was defaulting to my new (internet only account). Logged into xfinity on my computer and marked my other account (TV/Internet) as the primary account. Signed out of the Xfinity Stream App and reauthorized. Voila...Back to normal! Happy I Am!

New to the Community?

Start Here