Camoa1's profile

New Poster

 • 

1 Message

Tue, Sep 17, 2019 9:00 PM

Xfinity stream beta app for roku issues

My Xfinity app is stuck in initializing on my roku device.

This is an Insignia Roku tv, 55 Inches 2014 I believe. 6303X.

Roku version 9.10 build 421-15.

After several minutes it just says there is an error.

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

Frequent Visitor

 • 

15 Messages

2 y ago

Strange, both televisions just provided an activation code and once I entered on Comcast site, but televisions started working again.

Frequent Visitor

 • 

15 Messages

2 y ago

Having same issues on two televisions.  Removed app and reinstalled, still same results.  Stuck on initializing.  Other Roku channels work.

New Poster

 • 

1 Message

2 y ago

Hi, I’m new to this forum so not sure what I’m doing. Just looking for a solution to the same problem - my Xfinity Beta on my Roku has been “initializing” for 10 minutes. It finally looked like it was working (got the mural scrolling horizontally across the screen) so I excitedly hit enter and now I’m back to “initializing” 😞

New Poster

 • 

2 Messages

2 y ago

I had the same problem today. Stuck on initializing on both my Roku Premiere plus and my TCL Roku TV. I just rebooted my modem and router (my own equipment, not leased from Comcast) and that fixed the problem. After reboot both Rokus logged right in to the Stream app and can stream live tv.

New Poster

 • 

1 Message

2 y ago

Thank you so much - resetting the modem solved the issue!!!  You do have to reauthorize the app but everything  is working again....

New Poster

 • 

1 Message

2 y ago

Con't to work

New Poster

 • 

1 Message

2 y ago

Worked perfectly for me thank you so much!

New Poster

 • 

1 Message

2 y ago

For what it's worth I tried everything suggested. The one thing that worked for me was rebooting my modem. Not sure what was going on, but when my Xfinity on my Roku stick started this "initializing" thing, I also couldn't log into my Xfinity account connected to my wifi. So I rebooted and everything started working.

New Poster

 • 

1 Message

2 y ago

My Roku's have been working fine for months and now have been down for 3 days on the Xfinity Stream Beta app.  I keep getting a message saying that I need to connect to my home network when I am.  I have spent over 4 hours on the phone with Xfinity and have talked to the highest engineering support team.  We have restarted the modem and power cycled multiple times, I have restarted and reset the rokus to factory settings and rebooted, and I have removed and readded the Xfinity Stream App multiple times.  Each time, after I authorize, it still says I am not connected to my  home network.  I have verified MAC addresses, have no crazy router settings, and still can't get it to work.  I contacted Roku as well and they say it is an Xfinity problem and after 2 hours on the phone yesterday with Xfinity, they say it is a Roku problem.  I just want it to work.  I can stream from my computer and phone and the rest of my apps on the roku's work just fine.  Does anyone have other ideas? 

Rustyben

Expert

 • 

24K Messages

2 y ago


@ash27sept wrote:

My Roku's have been working fine for months and now have been down for 3 days on the Xfinity Stream Beta app.  I keep getting a message saying that I need to connect to my home network when I am.  I have spent over 4 hours on the phone with Xfinity and have talked to the highest engineering support team.  We have restarted the modem and power cycled multiple times, I have restarted and reset the rokus to factory settings and rebooted, and I have removed and readded the Xfinity Stream App multiple times.  Each time, after I authorize, it still says I am not connected to my  home network.  I have verified MAC addresses, have no crazy router settings, and still can't get it to work.  I contacted Roku as well and they say it is an Xfinity problem and after 2 hours on the phone yesterday with Xfinity, they say it is a Roku problem.  I just want it to work.  I can stream from my computer and phone and the rest of my apps on the roku's work just fine.  Does anyone have other ideas? 


did you try accessing the stream in the same home using the same username/password on a smart phone/tablet?

New Poster

 • 

1 Message

2 y ago

I am having same issue and have tried everything you mentioned. Resetting roku to factory settings, re started modem several times, deleted stream and adding it etc etc. This started when I switched modems but I have checked MAC address and it matches to what I have I even had an xfinity tech verify MAC and that modem was set correctly on their side. Still no luck.  Has anyone found any magic trick to make this work? 

Rustyben

Expert

 • 

24K Messages

2 y ago


@DeJaVu45 wrote:

I am having same issue and have tried everything you mentioned. Resetting roku to factory settings, re started modem several times, deleted stream and adding it etc etc. This started when I switched modems but I have checked MAC address and it matches to what I have I even had an xfinity tech verify MAC and that modem was set correctly on their side. Still no luck.  Has anyone found any magic trick to make this work? 


you didin't quote a post so same problem doesn't tell us anything. if you use a Roku and have installed the xfinity stream tv beta channel do you get to a menu for live/recordings/etc?

Frequent Visitor

 • 

6 Messages

1 y ago

I have the exact same issue as Ash, extremely frustrating.  Comcast tech teams not helping at all.  Been on with customer service for over 15 hours 5 days.  Still no live tv on roku.  I am unable to even authenticate.  I returned my X1 boxes last week.  Everything was working perfect.  Then all of a sudden, this issue.  Which frankly is really bad.  Troubleshot every device, power cycled everything (modem, router, tvs, rokus, signed out, in, authenticated, deleted app, everything 6 times or more.  Techs reading from the same script with no resolution.  Engineers giving me the runaround.  The problem is I can not use the Xfinity stream app on the Roku tvs or devices.  Laptop/tablet/phone TV stream works fine.   It is a problem with the Xfinity stream app, yet no one at Comcast seems to know how to fix.  Please help.  We are ready to switch to Youtube TV.

Rustyben

Expert

 • 

24K Messages

1 y ago


@Hopme wrote:

I have the exact same issue as Ash, extremely frustrating.  Comcast tech teams not helping at all.  Been on with customer service for over 15 hours 5 days.  Still no live tv on roku.  I am unable to even authenticate.  I returned my X1 boxes last week.  Everything was working perfect.  Then all of a sudden, this issue.  Which frankly is really bad.  Troubleshot every device, power cycled everything (modem, router, tvs, rokus, signed out, in, authenticated, deleted app, everything 6 times or more.  Techs reading from the same script with no resolution.  Engineers giving me the runaround.  The problem is I can not use the Xfinity stream app on the Roku tvs or devices.  Laptop/tablet/phone TV stream works fine.   It is a problem with the Xfinity stream app, yet no one at Comcast seems to know how to fix.  Please help.  We are ready to switch to Youtube TV.


you didn't quote ash (as I quote your post above). your cable video service may not be active since you returned all your set top boxes. call 800-Comcast and select billing and ask if your current subscription package includes the X1 internet and x1 video subscription package.

Frequent Visitor

 • 

6 Messages

1 y ago

I spoke to the billing team, customer owned video equipment with the super double play.  No X1 boxes on the account at all.  The Account has been Billing team says all the codes are correct.    Please help.  Billing can't help.

New to the Community?

Start Here