U

Visitor

 • 

1 Message

Mon, Jul 19, 2021 10:55 PM

Xfinity Stream App Stopped Working on Samsung Q60 TV - SOLVED

A few days ago, the app just stopped working.  It would just go to a blank screen and then after a few minutes a screen with "web page not available" came up.  I tried a number of things, including rebooting my TV and router.  I also tried reinstalling the Xfinity Stream app (my TV does not have an option to clear an app's cache).  I finally got it working again today.  (BTW, I tried working with Xfinity Support via Twitter - they were completely useless.)

  1. Cut power to Wifi router and TV (more than just pressing the "off" button).
  2. Power cycled my modem (powered off, waited a minute, and powered back on).
  3. Powered on Wifi router.
  4. Powered on TV.

Now, when I attempted to load the Xfinity Stream app, I got an error that the certificate for https://edge.stream-smarttv-samsung-active.xcr.comcast.net/index.html had in invalid date (ERR_CERT_DATE_INVALID).  I chose to accept the cert anyway and now Stream is working again.

I went to that URL with a web browser and the certificate seems to be fine.  It was just issued back on the 12th, so I assume the old one expired, which is what caused my issue.  The cert seems to only be for Samsung smart TVs, so I imagine this is causing issues for other folks.

I am not exactly sure what caused the app to suddenly prompt me to accept the cert again.  It's worth noting that, before power cycling everything, all my devices were having problems authenticating with Xfinity.

(Original Xfinity Stream app error on Samsung TV)
_
(Message after power cycling everything)
_
(New certificate via web browser)

Responses

No Responses!

New to the Community?

Start Here