melsailsnorth's profile

Frequent Visitor

 • 

16 Messages

Sun, May 19, 2019 12:00 AM

Xfinity stream app/ Roku - Quit initializing: Sorry, something went wrong, try again later.

Once again, my Xfinity Stream app on my Roku device has quite working.   Same issue as a few months ago.  Start the app in Roku, app say "initializing" then I get a black screen that says-

Sorry!

Something went wrong. Please try again later  (Error). 

No code or anything.  Tried the previous advice, deleting app.  Hard restart of modem/router. Erased Roku back to factory specs, then reinstalled the Xfinity stream app.  Once everything back on line, restarted app but no joy. 

Last time it just started working again after about a week once a new update came out for the beta program.  Would be nice to hear from any others that are experiencing similar or are most systems on Roku still working fine?  Xfinity streaming still works fine if accessed via computer.   Everyone is missing live tv so would be nice to have it back with a fix again. 

Thanks, 

Mel

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

CCElla

Silver Problem Solver

 • 

3.3K Messages

2 y ago

Hello, melsailsnorth! Thank you for posting in our community! The app is still in Beta status, we are still trying new configurations, some of them work, some of them fail. I can definitely check your account and troubleshoot the issue. I got your private message and will reply back in a minute. 

comc25

Regular Contributor

 • 

117 Messages

2 y ago

Lol it’s been in ‘Beta’ since 2016.

Frequent Visitor

 • 

16 Messages

2 y ago

Ya, the longest beta run in history, lol..   Was hoping to get at least some feedback from other users to see if this indeeed was something isolated to my system, or if others are having similar issues.    I'm to the point (if it's isolated) that I'm ready to go out and buy a whole new ROKU system if it's a possible fix. 

I have no cable aside from this and I miss my local news at night.    It's either this or go invest in a 100 mile antenna to try and pull the signal in that way.   Thanks in advance for any feedback from other users!

Regular Visitor

 • 

4 Messages

2 y ago

I have the same problem and have tried the same solutions with no luck.

Regular Visitor

 • 

4 Messages

2 y ago

I have the same problem and have tried the same solutions with no help.

Regular Visitor

 • 

4 Messages

2 y ago

No...I am still scratching my head. The last attempt with a Comcast technical support was to do a complete factory reset with my Roku. We tried with a complete new Roku account but the xfinity channel would not delete to reinstall. I was told to contact Roku for help with this issue and to call back when solved. BIG PROBLEM. Roku has absolutely no technical support. By the way, the phone number I was given by Comcast for Roku technical support turned out to be a third party scam!

 

Now that I have found your forum and searched, at least I know someone else is experiencing the same problem. Any suggestions?

thanks harry

Official Employee

 • 

35 Messages

2 y ago

I do show the ticket is still open. Did they get in contact with you regarding this request? 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Official Employee

 • 

35 Messages

2 y ago

I understand, I do apologize for the troubles with this. The teams working this ticket are still reviewing this. Once they know more or need to have you check something they will follow up with you directly to see what can be done to assist. 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Solution.tick

Frequent Visitor

 • 

16 Messages

2 y ago

Really appreciate you taking the time to post here and it's nice to know I'm not the only one this might be effecting.   I PMed you also. 

Mel

Frequent Visitor

 • 

16 Messages

2 y ago

They must be making some small progress on the issue.  I was able to authorize and bring up my streaming account on Roku for a couple hours today but as soon as I stopped the program, it would not let me back into it.  I guess a couple hours is better then nothing 😜

New Poster

 • 

1 Message

2 y ago

Im having the same issue for multiple days now. Says something went wrong and to please try again. Any help would be appreciated.

Frequent Visitor

 • 

16 Messages

2 y ago

I went through it for a solid month, trying everything you can imagine.  Bottom line (if its the same issue) is that it's most likely software/account registration related and nothing you do at home is going to have any effect.  Just get in touch with one of the mods here and have them open a support ticket for you so that support can work on it on their end.  They can reset your account which seems to have positive results.  Comcast will try and (robocall) you and if you don't answer, they will close your support ticket regardless of the status of your issue.  It can be a frustrating and ongoing but keep determined and have the good folks here on the forum keep your ticket open for you till things get resolved.   Eventually they will get it back up for you.  

**If things go too long without their help, login to FCC website and file a consumer complaint (just takes a couple minutes).  This will get their upper managment to jump all over your issue within a day or so.    Not sure if they will erase the post once they read this part, but it's good for folks to know they still have options when all of Xfinity's conventional methods keep failing miserably. 

Best of luck! 

New Poster

 • 

5 Messages

2 y ago

I’m having the same problem, and on the streaming apps on my tablet and phone as well. Four days now with no cable.
ComcastKenF

Official Employee

 • 

8K Messages

2 y ago

Hi Everyone. 

 

 

Truly appreciate you all taking the time out of your busy day to let us know your issues with the XFINITY Stream Beta app on Roku. I understand how frustrating it is for something to work one day and then not the next. Our goal here is to get you up and running so you can enjoy all of your favorite programmings via our convenient app. 

 

MJMJS, it sounds like your concerns might be account specific so I'd be happy to look into that personally. Please send me a private message with your full name for assistance and we'll get you up and running ASAP. 

 

As far as troubleshooting the Roku Stream app, please follow these troubleshooting instructions precisely: 

 

1. Restart Roku 
2. Uninstall XFINITY Stream app 
3. Restart Roku 
4. Install XFINITY Stream app 
5. Restart Roku 

 

Please also check what WiFi frequency your Roku is connecting to. I suggest using band-steering on your modem. Often time if the Roku is picking up the 5ghz over 2.4ghz, an error will occur. 

 

Ken

Regular Visitor

 • 

2 Messages

2 y ago

This solved the issue I was having. It appears the App had on update on 11SEP2019 and the App did not autoatically update for some reason.  Deleting and reinstalling resolved the problem for me.

New to the Community?

Start Here