sabla102's profile

New Poster

 • 

1 Message

Sun, Sep 8, 2019 12:00 PM

Xfinity Stream app not playing anything on Roku

I have just connected my Roku to the TV and have added Xfinity stream beta as a channel. When I play other channels on Roku they play the content fine. When I try to play anything on the Xfinity Stream beta app, it buffers for a second then it will pause and reset the roku device. I have tried deleting the channel, resetting the device and reinstalling the channel and I have also tried a power cycle. Please let me know what else I can try. 

 

Thank you 

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

New Poster

 • 

1 Message

2 y ago

You perfectly described the exact same experience I'm having and the troubleshooting I've tried. I've had the same TV, Roku, and service for over a year so not a thing has changed on my end. This just began happening here yesterday on 9/7 and continues.
Rustyben

Expert

 • 

24K Messages

2 y ago


@sabla102 wrote:

I have just connected my Roku to the TV and have added Xfinity stream beta as a channel. When I play other channels on Roku they play the content fine. When I try to play anything on the Xfinity Stream beta app, it buffers for a second then it will pause and reset the roku device. I have tried deleting the channel, resetting the device and reinstalling the channel and I have also tried a power cycle. Please let me know what else I can try. 

 

Thank you 


standard fix is to highlight the channel and press the * (star) button the roku remote and remove the channel. then unplug the roku from HDMI and from its power plug for 30 seconds or more. plug back in and reinstall the channel. be sure to approve the terms and conditions. now working?

New to the Community?

Start Here