djf55020's profile

Frequent Visitor

 • 

6 Messages

Mon, Apr 20, 2020 6:00 PM

Xfinity Steam Beta on Roku - TVAPP-00101

Yesterday I swapped out my owned cable modem with a new one.   The swap went fine.   Within a few hours each of my 3 ROKU devices running the Xfinity Stream app started giving me the error"  This device can only access Xfinity StreamOn your home Xfinity Wifi.".   I am in my home!  I am connected to the same router as before.   I suspect from my research  here that the modem switch has caused this problem, but I don't know how to correct it.    I've tried calling support but they tell me that because it's BETA they can't do anything.   Any help is restoring my Xfinity Strem Beta on Roku would be appreciated.

 

Edit:  I looked at my account and I can see that the Serial number listed with my modem is the MAC address of the modem, not the serial number.   When I called back to speak with the agent they said it was set up correctly on my account and was not an issue.  They said if it was incorrect, my modem would not operate.  Not sure if this a problem or not, but it looks wrong to me. 

Responses

Accepted Solution

djf55020

Frequent Visitor

 • 

6 Messages

1 y ago

I got it working.   Yesterday I was trying to activate through a browser on my android phone.   Today I tried a PC/browser and it worked fine.    Maybe you can't activate on a phone even if it's connected to your home wifi.    

New Poster

 • 

2 Messages

1 y ago

Thank you for this!  I was attempting to activate using my iPad, and was having no success.  Based on this review, I skeptically tried it from my PC, and it worked!

 

This is a very strange solution, but I am glad you shared it.  The last thing I wanted to do was to call Comcast!

New Poster

 • 

1 Message

10 m ago

I had the same error, because I'm using my own modem, not Xfinity's. I just had to call tech suport and tell them the make/model and MAC address for my modem and now my Roku works fine.

New Poster

 • 

2 Messages

9 m ago

Error tvapp 00500 ..i rebooted and still nothing works..please Help

New Poster

 • 

2 Messages

9 m ago

Error tvapp 00500 ..i rebooted and still nothing works

New Poster

 • 

1 Message

9 m ago

Same problem here today. XFINITY says it has no clue. They put in a ticket 🥺

New Poster

 • 

2 Messages

9 m ago

Try activating your Roku using a pc instead of a mobile device.  This worked for me.

New Poster

 • 

1 Message

9 m ago

When I connect it continues to pull up purchases from and old canceled account. Please help
Rustyben

Expert

 • 

24K Messages

9 m ago


@MylesLane07 wrote:
When I connect it continues to pull up purchases from and old canceled account. Please help

you won't lose your old purchases as you can still access. Do you have a new address/account? If so, you may want to move your purchases to the new account.

New Poster

 • 

3 Messages

9 m ago

I'm having the same issue.  I just turned in all 5 of my cable boxes

Bought new Roku TV's and downloaded the app. Worked great for a week. Last night the app stopped working on all of the TV's. Nothing was changed on my end. 

"This device can only access xfinity stream on your in-home Xfinity Wi-Fi"

I'v been on with Customer Service for 3 hours troubleshooting ( most of it I had already done myself) Resetting Modem, installing and uninstalling app, resetting network connections etc...anyone have a fix for this. App works on phones and Ipads and all other apps are working fine. 

They tried handing me of to Roku but it's not their issue. I have an Xfinity Modem.Help?? 

New Poster

 • 

3 Messages

9 m ago

 That information was not provide when I turned in my boxes. (I'll see if thats how they have my account set up ) However It has been working on Multiple devices with no boxes in the house and all of a sudden it's not. So with what you mentioned I should be able to access it with at least 2 of the TV's at one time. At the moment I cannot get 1 to work...

 

Edit* I just looked it up and you can have up to 45 devices registered and 5 streaming at the same time..Doesn't say anything about needing a box..

Rustyben

Expert

 • 

24K Messages

9 m ago


@wwilliams272558 wrote:

I'm having the same issue.  I just turned in all 5 of my cable boxes

Bought new Roku TV's and downloaded the app. Worked great for a week. Last night the app stopped working on all of the TV's. Nothing was changed on my end. 

"This device can only access xfinity stream on your in-home Xfinity Wi-Fi"

I'v been on with Customer Service for 3 hours troubleshooting ( most of it I had already done myself) Resetting Modem, installing and uninstalling app, resetting network connections etc...anyone have a fix for this. App works on phones and Ipads and all other apps are working fine. 

They tried handing me of to Roku but it's not their issue. I have an Xfinity Modem.Help?? 


when you turn in your 'last' box so none are on the account, you have to sign up for a no-equipment cable channels package. note that without at least one set top box only 2 streams of any kind can be used at a time. with at least one set top box the limit goes to 5.

Rustyben

Expert

 • 

24K Messages

9 m ago


@wwilliams272558 wrote:

 That information was not provide when I turned in my boxes. (I'll see if thats how they have my account set up ) However It has been working on Multiple devices with no boxes in the house and all of a sudden it's not. So with what you mentioned I should be able to access it with at least 2 of the TV's at one time. At the moment I cannot get 1 to work...

 

Edit* I just looked it up and you can have up to 45 devices registered and 5 streaming at the same time..Doesn't say anything about needing a box..


the have-no-active-box-on-the-account is new and is limited to 2 devices and 2 tuners to record. just add a set top box back to the account and you are fixed.

New Poster

 • 

3 Messages

9 m ago

Ok Thanks I'll try that and hop back on here if it doesn't work..Thank you

Visitor

 • 

1 Message

3 m ago

Anyone have a fix to this? Tried logging in on PC with no luck. I have 1 set top box, put a new modem in last week, everything was good all week until last night I started getting the TVAPP-00101 error. Comcast rep couldn’t fix... submitted a ticket. 

ComcastAbbie

Official Employee

 • 

319 Messages

@user_783658 Hello and thanks for reaching out to us regarding your app TV. I would like to get your account pulled up since a ticket was already submitted. Can you please reach out through private message (by clicking on the chat icon on the top right of the page) with your first and last name, name on the account if different, and service address?

New to the Community?

Start Here