gtilley's profile

Frequent Visitor


15 Messages

Wed, Nov 20, 2019 11:00 AM

Xfinity Remote app stopped loading devices

"Xfinity Remote app" stopped loading devices. I turned one of my 4 boxes in yesterday and I then accessed the remote app. I noticed turned in device still showed ( It wasn't showing in account app), so I logged out and logged back in. After this, there are 0 devices. I'm on X1 platform and my devices have always worked with remote app more many years actually. I tried signing out and signing, signing in other alternate user name. I deleted app and reinstalled. I deleted all of my xfinity apps, did a hard reset on iphone 11 pro and resent my entire xfinity home system. I chatted with level 1 and level 2 support, they reset my boxes and had me log out and log in. Nothing has worked. Next level 2 said they researched and this is a known problem and many people have opened tickets and they are working on a solution. I had them check and tell me when the issue stated and when the expect it to be resolved. They came back and a 3 min wait and said 1 week about the issue started and estimated time to fix was Nov 28th. 


I then google search and saw my same problem happening back in 2017! it was posted in this forum. The Comcast person in forum had sent them an instant message and they resolved the issue somehow. I feel this issue is ongoing and will not get fixed if I just wait it out. So, someone with comcast get back to me and lets resolve this issue.

This conversation is no longer open for comments or replies and is no longer visible to community members.


No Responses!

New to the Community?

Start Here