U

Visitor

 • 

7 Messages

Tue, Sep 28, 2021 4:50 PM

When I log on to the xfinity app on my laptop, I get the home page, but I can't access the "Video" link

I have a MacBook Pro. I am running the latest version of Big Sur o/s. Recently, I have a problem with the xfinity homepage. I log into the page, but I can't access the "Video" link, so I cannot see my channel and program lineup. Anyone else seen this problem?

XfinityJoeB

Official Employee

 • 

6.9K Messages

1 m ago

Hello user_d980b0. Thank you for creating a post on our Forum. I can assist with troubleshooting your Xfinity Stream access to watch your programming online. Can you please tell us more about what happens on screen when you try to access the video link, Stream? Do you get an error page, or blank screen? 

Visitor

 • 

7 Messages

@XfinityJoeB  Thanks for responding . . . my intent is not so much to stream video on my laptop, but rather check out my channel lineup, my saved recordings and "favorites", etc. As to what happens, I access the xfinity app on my laptop, log in as appropriate, and hit the video link (other options being wifi, voice, home). . . and I get a dark screen with three dots moving to the right. Nothing else happens. If I hit refresh, it just cycles through again. I h proave always been able to see the lineup, daily programming, favorites and recorded shows. 

Mind you I have a MacBook Pro, and I am running it under the latest Big Sur OS.  Thanks, JM

Official Employee

 • 

301 Messages

Thank you for the details @user_d980b0. I am sorry to hear about your troubles accessing the Xfinity Stream App. I can understand your frustration from personal experience. We are currently working on an issue with customers using Apple computers (MacOS devices) on MacOS 11.6 running the newly released Safari 15.0. Based on the information you provided, it sounds like you are experiencing the known issue. The work around at the moment is to use a different browser. For the sake of troubleshooting, can you try a different browser? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

7 Messages

@XfinityAnna Hi, Anna, Thanks for the update. I kind of figured that the problem was associated with the Big Sur Mac OS upgrade, because my problems occurred soon after the several upgrades installed on the laptop. Re: using a different browser . . . I don't have one. I use Mac software exclusively. Does that mean that xFinity is not taking steps to address it? It seems that others are in the same boat as me. I can use my iPhone to get to the channel lineup screen, but that was after several iterations trying to get to it, and when I did, I failed to record my steps on how I got there! Please let me know what steps you folks are taking and when I can expect a resolution? Thanks for your follow-up, and look forward to a response from you or another representative. Regars, JM

Official Employee

 • 

301 Messages

We sure do appreciate your patience and understanding, @user_d980b0. We do have a team working to resolve the problem ASAP. No resolution time has been provided yet. I promise as soon as we have updates to share, we will let everyone know. In the meantime, if you have any additional questions or concerns don’t hesitate to reach out to us. Our team is available 24/7 to help. Thank you for being a loyal Comcast customer.

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

7 Messages

The question was answered, but the solution has not been identified. Apparently this is an outstanding issue, and xFinity has a team assigned to it. The temporary "fix", which is to use an alternate browser, is not acceptable. I look at being about to browse my channel lineup, programs aired, and movies available, as an integral part of the package that I am paying for. So far, I'm not getting what I'm paying for. Please let me know when I can expect a permanent fix on the part of xFInity. Regards, Jim M

Visitor

 • 

1 Message

19 d ago

Same with me .  I chatted with Assistant last night with assurance it would be fixed in 60minutes.  still does not work.  very frustrated with x-finity.  Their website sucks

Visitor

 • 

7 Messages

15 d ago

This is addressed to any "Official Xfinity Employee" . . . when do you expect that a fix will be developed and installed which enables Mac users to access the Video option from the home screen. There are folks who actually use this feature to review channel lineups, programming, set recordings. That would include me.

Official Employee

 • 

297 Messages

@user_d980b0 Thank you for reaching out to the Digital Care Team. I hate to hear this has been your experience and would love to investigate this for you! Are you using Safari 15 with Mac operating system 11.6? 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

7 Messages

@XfinityHeather  In answer to your question, I am using the latest versions of Safari and O/S. . . Safari 15 and Mac OS 11.6 Big Sur. I am concerned that while Xfinity knows about this issue, as indicated in my discussion thread, it is not being addressed. The "Video" link on the Xfinity home page is an integral tool, and I use it to scan my channel lineup and programming, and it allows me to set recordings, etc. I am paying for this tool, but I am not able to use it. The symptom of my problem is that when I click the Video link, I get a blank dark screen with a series of white dots "moving" to the right. It will stay that way. I can refresh the screen, but the results are the same. What I am looking for is an acknowledgment from Xfinity that this is a know problem and it is on the docket for some sort of resolution. Until then, I don't see any sense marking replies an an "Accepted Answer". Regards, JM

Official Employee

 • 

297 Messages

@user_d980b0 This is a known issue that we are working to resolve. I apologize you are effected by this situation. We hope to find a solution soon, so you can get back to streaming. 

I am an Official Xfinity Employee.
Official Employees are from multiple teams within Xfinity: CARE, Product, Leadership.
We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Please, mark a reply as the Accepted Answer.tick

Visitor

 • 

7 Messages

@XfinityHeather  Another week has gone by, so I'm checking in to ask when I'll be able to use the video link on my xfinity home page? Why do I get the feeling that xfinity is just letting this drag on in the hopes that schmoes like me will forget about it, and ultimately the link will be eliminated? You folks did that with the "phone on the go" feature. I don't know about others, but I used to check the video programing daily to plan my recordings and streaming. Now I don't have it, and it has been weeks since I originally posted my issue. Come on, xfinity . . . do something.

(edited)

New to the Community?

Start Here