jgirardnrg's profile

Frequent Visitor

 • 

9 Messages

Mon, Apr 20, 2020 4:00 PM

New cable modem, Xfinity stream on Roku stopped working

I bought a new cable modem recently to replace the Xfinity modem. Now all 3 TCL Roku TV's get an error message when we try to use the xfinity stream app:

 

This device can only access xfinity stream on your in-home xfinity wifi ...

 

I can watch on my computers as well as my ipad but not via the Roku on the TV's.

 

Support send a signal and rebooted the modem. We've uninstalled and reinstalled the app. I've tried all of the other solutions on the forums and have had zero luck. I did come across a post where @ComcastMorgan was able to send a signal paired with a database refresh that got someone else's Roku working again. Help?

Responses

Accepted Solution

jgirardnrg

Frequent Visitor

 • 

9 Messages

1 y ago

Talked to Advanced Repair Dept this morning and they got it sorted out.

andyross

Silver Problem Solver

 • 

6.9K Messages

1 y ago

Comcast uses your modem info to verify it is yours. Just because it's working for Internet doesn't always mean it's properly tied to your account. You can check your account info online or through their app at Comcast and check the equipment list to see if the modem info matches your modem.

jgirardnrg

Frequent Visitor

 • 

9 Messages

1 y ago

It does... I checked that while trying to troubleshoot on this end. When I switched I wasn't able to provision the new modem without calling and everything was verified and working before we got off the phone.

jgirardnrg

Frequent Visitor

 • 

9 Messages

1 y ago

@ComcastStream can you offer any insight?

jgirardnrg

Frequent Visitor

 • 

9 Messages

1 y ago

No one?

Rustyben

Expert

 • 

24K Messages

1 y ago


@jgirardnrg wrote:

No one?


if you use a smart phone/tablet using the same wifi SSID (your home wifi) does the app work normally without issue?

jgirardnrg

Frequent Visitor

 • 

9 Messages

1 y ago

Yes... I streamed all last night on my iPad and my computers also all work without issue. The only issue we're having is with the 3 Roku TV's in the kids rooms.

Rustyben

Expert

 • 

24K Messages

1 y ago


@jgirardnrg wrote:

Yes... I streamed all last night on my iPad and my computers also all work without issue. The only issue we're having is with the 3 Roku TV's in the kids rooms.


go to one of the TCL/roku TVs and select the Xfinity Stream Beta app. use the menu to sign out. after signing out, unplug the TV from power for 1-3 minutes. plug back in. select the Xfinity stream app and sign in (be sure to answer yes to agrreing with the terms and conditions). working on that TV now?

jgirardnrg

Frequent Visitor

 • 

9 Messages

1 y ago

Would be great if one of the Comcast employees here on the forum would take a look at the account and make sure everything is as it should be.

jgirardnrg

Frequent Visitor

 • 

9 Messages

1 y ago

Nope... I just called support as well. Spoke to 4 different people and need to call the advanced repair dept tomorrow since they're closed at the moment.

Regular Visitor

 • 

3 Messages

1 y ago

What did they have to do?

New to the Community?

Start Here