Cmjones2829's profile

New Poster

 • 

1 Message

Wed, Dec 23, 2020 7:00 AM

Continued problems with xfinity stream

I have three Samsung Smart TVs. Two connected by Wi-Fi and one with Ethernet cable direct from router. I have been experiencing problems with Stream for over a year. I have restarted my router, uninstalled app, unplugged tv reinstalled app at least 100 times.
Problems: About every three to four days the Streaming app will not load. I get error message “Something went wrong. TVApp-00100. I then have to go thru the delete app/reload procedure several times until it completes. Same problem on all three TVs but they are not synced-they fail at different times
Second problem- poor resolution on several channels. Picture will be in HD and suddenly get really bad. Then clear up. Repeats until I reload app again.
Have contacted tech support with first problem numerous times. Always told to reset my router. Router is fine. TVs work great on all other streaming services except Xfinity

Ready to scrap Xfinity. Any solution suggestions? Do I need to abandon Streaming and install set top boxes (major install)

Responses

Official Employee

 • 

2.7K Messages

6 m ago

Hello, @Cmjones2829! Welcome to the Xfinity Forums!

The Xfinity Stream app is still in beta for smart TV's, so issues like this are to be expected as we continue to develop the app. Regardless, I can definitely see how the process of reinstalling the app so frequently would be a bit tedious. 

We would be more than happy to check out your account settings and service levels to see if we can help you have a better experience with the app! Please send me a private message with your first and last name, as well as your service address so I can assist. 

 

 To send a private message, click my name "ComcastTambrey", then click "send a message".

New to the Community?

Start Here