MrHo's profile
MrHo
1st Kudo
1st Best Answer
1st Reply

New Poster

 • 

3 Messages

Sat, Mar 2, 2019 9:00 PM

Problem with MMS since update to android pie

I have a galaxy s9 which recently updated to android pie. Ever since, I've been unable to send or receive MMS messages....regular texts work fine. I've gone thru several online trouble shooting steps without success. Other forms of mobile data work fine. One of the online trouble shooting steps suggested checking the APN in carrier settings. However, when I attempted to check the settings the screen says "Access Point Names not available for this user". Is this normal? What else can I do short of completely wiping my phone and starting from scratch? Are there network settings on the carrier side that need to be changed?

Thanks

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

New Poster

 • 

2 Messages

2 y ago

SMS(TEXT) uses the tower network that we see as bars on our phone. MMS (MULTI-MEDIA MESSAGE(S)) use Data or LTE (LONG TERM EVOLUTION) technology.
In today's age, most of the the Verizon towers, (Xfinity Mobile purchased the rights to use these towers for the foreseeable future)
Have the data or LTE transmitters and transponders attached. They used to be separate.

No matter how close these two technologies are to each other, the fact remains, you cannot send an MMS, without mobile data. Plain and simple. It is IMPOSSIBLE to send it via text. That technology does not support that. SMS does not have data capabilities.
NOW, you can be fooled into thinking "oh, my mobile data is off but I can still send pictures".
Sometimes this will work because your phone will still use data to send the MMS even though your mobile data is off.

My note for example will do this sometimes. It's some sort of communication between the snapdragon processor and the Qualcomm tech inside it's "guys".

Again, this will still use data, if you are able to send the MMS with the switch off.

I'm regards to billing, sending MMS messages DO NOT count towards your monthly data. Never have, never will. They are covered under the unlimited talk and text agreement they give us for having their internet service. (since you cannot have Xfinity Mobile without first being on the Xfinity Internet system)

New Poster

 • 

2 Messages

2 y ago

So what happened to that 2 weeks until the fix rolled out estimate? I am still having this issue with OE and 3rd party apps - even if I leave data on, wifi being on at all disables sending and receiving MMS. S10+

Edit to clarify:
I always leave mobile data on. I just can't send or receive MMS if my wifi is turned on.
CCKenF

Gold Problem Solver

 • 

8K Messages

2 y ago

Sinistrahd so you're unable to get any MMS message regardless of your data connection or app? You've used the Verizon messaging app as well? I think it came preloaded in the Samsung devices. 

 

Ken

New Poster

 • 

2 Messages

2 y ago

Ken, I have not tried the Verizon app, my phone only had the default messages app on it, and I have since gotten textra on several recommendations from both comcast employees and users here having similar issues. The same issue occurs using textra. I am willing to try the Verizon app if you think that will work where textra does not.

Thanks for the suggestion!
ComcastChe

Official Employee

 • 

6.1K Messages

2 y ago

@Sinistrahd, yes, we do think that may help. Can you test it out and let us know if there is any change or not? 

I am an Official Comcast Employee.
Official Employees are from multiple teams within Comcast: CARE, Product, Leadership. We ask that you post publicly so people with similar questions may benefit from the conversation.
Was your question answered? Mark the post as Best Answer!tick

New Poster

 • 

3 Messages

2 y ago

@CCKenF   

2 years ago my husband and I both purchased LG X Charge phones when we switched to Xfinity Mobile. With both Data and Wi-Fi turned off, we could send MMS. (These phones were on Android IOS 7.0) A few months ago we bought my daughter a Moto e5, again with her Data and Wi-Fi turned off she can send MMS. (Her phone is on Android IOS 8.0.0) Everything was good. 

My phone broke a few weeks ago, went to the store to buy another. LG X Charge was no longer available, so I purchased an LG K30. (New phone is on Android IOS 8.1.0) Got it all set up at the store, then on the way home (with Data turned off and no Wi-Fi) I tried to send a group text (MMS). Was surprised to see that the upper corner of my screen said "No connection" and the message would not send - below the text box it said "Waiting for connection." After a day of "playing around" with every setting I can find (and comparing them all to my husband's and daughter's phones), it does not appear to be a "settings" issue. I CANNOT send MMS with both Data and Wi-Fi off like I could with my old phone. 

I have enabled both "Enable usage of cellular data in the background" and "Allow unrestricted data access when Data saver is on."

 

As recommended by some others, I tried the Messages+ app.  Again, I was unable to send messages without data on.

 

Any further updates or solutions?  I always kept my data turned off before.  Now that I have it on all the time, my data usage has tripled even though I have turned off background data for every other app.  This "inexpensive" phone is going to end up costing me an additional $12/month.  I'd love to hear there's a way to fix it!!

Contributor

 • 

24 Messages

2 y ago

. They just blocked my earlier reply with some error message. The average user will turn on mobile data and be on their merry way. Not knowing they are charged data usage for a text message

New Poster

 • 

3 Messages

2 y ago

Additionally - I have the same issue when using Textra.  If Wi-Fi and Data are both off, it tries to send for awhile and then I get a "failed" message.  I changed the carrier limit to 600 as was suggested.  This made no difference.

 

I e-mailed LG about the problem, they said, "In some devices, mobile data connection may be enabled automatically when an MMS message is pending – thus, eliminating the need to manually enable Mobile Data.   Since Multimedia Messaging System (MMS) services are provided directly by the carrier, you may also consider getting in touch with this if such automatic connection is one that will have to be provided to you as a setting."

 

This did not help me, but I wondered if there is a "setting" that Xfinity could provide to allow an override?

 

Thank you!

New Poster

 • 

5 Messages

2 y ago

CHANGE YOUR DATA SAVER FEATURES!!!!!!!

New Poster

 • 

1 Message

2 y ago

Just switched from Verizon and bought a Galaxy10+ ($1000) same issue. CDant send or recieved MMS via WiFi which is a major problem for me... What messaging app did you switch too/ are you using? thanks


New Poster

 • 

3 Messages

2 y ago

Just like everyone else I have recently run into this issue.  I used to have unlimited data so never thought about it, switched to by the gig and turned off mobile data and can’t send simple pictures or group messages as they are considered mms, along with long messages.  I know my S7 with xfinity mobile and before that with prepaid carriers and all the way back to flip phones you could send pictures via text data plan or not.  It would be nice if we had options to get into the APN cause I’d venture it’s something there that xfinity changed when they got the update for pie or wherever it started happening at.  I’m supposed to have unlimited text and yes pictures are part of text as that has been the precedent in my usage since phones could take pictures.  Get this fixed.

 

ps I’m also may just be me not seeing time or date stamps from when people post....8/30/19 8 PM

DaveO3

Problem Solver

 • 

288 Messages

2 y ago

SMS can be sent without cellular data active. However MMS will need cellular data active, even if you are on wifi. MMS messages are multimedia messages, but are also sent when sending group messages, any message with any accents or special formatting or emoticons, or messages longer than 140 characters.

 

The exception to this is if you have wifi calling active. If you have wifi calling active and you have the indicator XM Wi-Fi in the status banner where Xfinity Mobile usually is, then you can send MMS messages over wifi. You can force wifi calling active by making sure it is turned on in Settings - Phone and then putting the phone in airplane mode and turning on only wifi.

 

Remember, even though MMS text messaging requires cellular data to be turned on, if your are not on WiFi Calling, using data to send an MMS message does not count against your total.

M0710NM4N

Frequent Visitor

 • 

13 Messages

2 y ago

I can for 100% certainty that prior to Pie I was sending pictures and even video WITHOUT DATA turned on and WITHOUT wifi calling on because I was doing this left and right during a night it was snowing sometime around this past Christmas. Then Pie came out and nothing but problems. Without DATA on, pics etc will sometimes go through and sometimes not and then I have to turn DATA on. It's like it has a mind of it's own. It's been months now and no fix.

New Poster

 • 

3 Messages

2 y ago

This does not work.  I contacted Comcast customer service several times over the past week and no one knows how to fix the issue.  It has been several months since the update.  I'm about to switch carriers.

M0710NM4N

Frequent Visitor

 • 

13 Messages

2 y ago

It for sure is frustrating when nothing gets done about an apparent problem. Bad enough we can't get a real caller ID and have to settle for "Mobile Caller" when we call someone. My poor mother has to screen all her calls because of spam calls and has to screen my call as well since it can't show my name. Never had that problem with another "big name" carrier in the past. For how big of a company they are... you would expect things like this to not be an issue.

New to the Community?

Start Here