peterka09011's profile

Contributor

 • 

34 Messages

Tue, Aug 31, 2021 11:25 PM

Closed

My Callers Must Now Enter My Phone Number to Leave Me a Voicemail, Every Time??? "Message Management System"???

Suddenly as of today, my iPhone X's voicemail answers my callers with "Welcome to the Message Management System" and tells them to first type in my phone number to leave me a voicemail. Then they hear my personal greeting asking them to leave a message. I have had this iPhone 10 for 3+ years and have changed nothing in settings, etc.

I killed 2 1/4 hours on the phone just now with Xfinity Tier 1 and 2, then the Tier 2 guy chatted with Verizon to further diagnose, and after multiple resets including an iPhone Network reset (which wiped out all my wifi passwords), the Xfinity Tier 2 tech transferred me to Apple. He said Verizon did everything they could, as did he. The Apple guy was a first-level tech who had me do another Network reset and then failed to call me back.

I have an iPhone X with iOS 14.7.1

My clients will not take kindly to typing in my phone number to leave me a VM, and I am am my wit's end! Please, if anyone has fixed a similar problem, please let me know!

Thank you

Contributor

 • 

34 Messages

3 m ago

Does Xfinity even read these posts? 14 hours and no acknowledgement. My voicemailbox is still saying "Welcome to the Message Management System" and forcing callers to enter my 10-digit phone number in order to then hear my voice greeting and leave me a message!

DaveO3

Problem Solver

 • 

364 Messages

3 m ago

This is a user forum and Xfinity does not usually provide answers other than to call or text Xfinity support. 

My guess is that since voicemail is based on call forwarding that something went wrong with your call forwarding and it thinks that you are calling to get your own voicemail from another device. I suggest that you turn call forwarding on and off for all of the options shown in the support link below:

https://www.xfinity.com/mobile/support/article/how-to-use-call-forwarding

Worth a try!

Note: If a caller presses * to try to interrupt your message they will be directed to the voicemail management system. 

(edited)

Contributor

 • 

34 Messages

@DaveO3  Dave- I tried this - the first call , *71 and/or *72 to turn on call forwarding, did not go through - I heard some kind of error message.

However... then I dialed *73 to Turn Off Call Forwarding - and voila, the "Message Management System" is gone - and once again my voice answers the call!

I have never turned on call forwarding, so it never occurred to me to try to turn it off - thank you!

I wonder how many others have been utterly frustrated that Xfinity Support has no knowledge of this simple fix?

New to the Community?

Start Here