tyler889's profile

New Poster

 • 

1 Message

Tue, Nov 12, 2019 7:00 AM

MMS sending and receiving issues

I switched from Verizon Wireless to Xfinity Mobile on 11/9/19. I brought my unlocked Samsung Galaxy S10 over to Xfinity. Since the moment I switched I have had issues with sending and receiving MMS and group text messages. The issue is when I have WiFi and Mobile data turned on. If I turn off WiFi the MMS will transmit. I did not have this issue when on Verizon Wireless. I talked to a Xfinity tech via chat and they said I should be able to have WiFi and Mobile data turned on at the same time and be able to send and receive MMS. He suggested I reset the network settings. I did this and I'm still having the same issue. I searched the forms and this appears to be an issue for others once they switched to Xfinity. Is there anything that can be done to resolve this issue?

 

Related post:

https://forums.xfinity.com/t5/Xfinity-Mobile/MMS/td-p/3265469

 

@Comcast_Support 

This conversation is no longer open for comments or replies and is no longer visible to community members.

Responses

DaveO3

Problem Solver

 • 

306 Messages

4 m ago

Your only solution may be to reset the device to original settings if resetting network settings and updating software hasn't worked. Basically erase all content and start over. Get SMS and MMS working before trying to enable any advanced messaging options. 

New Poster

 • 

1 Message

4 m ago

Thank you for this. Are there any new lights about this issue? My wife’s phone is having this issue but hers is a Samsung Galaxy Note9 BYOD and my iPhone 11 I bought from you when I upgraded. I don’t have an issue sending any MMS over xfiniit mobile. Only my wife does. Why is this?

New to the Community?

Start Here