U

Visitor

 • 

1 Message

Wed, Oct 13, 2021 7:44 PM

LTE service says full, yet no working data for internet access

Seems like this is a bad trend. Update your phone like your supposed to, in order to keep features working! Now, my cell signal says four bars full, but I’m areas with service and should have service, I get nothing. Internet times out, things just won’t work. I’ve also noticed over the past 1.5 years that areas that once had full LTE, now have 1 bar at best! No service a lot of the time. Is this due to the new IPhone 12, and my guess i “should upgrade” 

this is a consistent situation, an keeps happening!!

I’ve tried 

restarting phone 

turning off data and back on. 
roam off an on,

reset network 

Redo phone. 
Signal used to be strong.. now weak. Bad seeing I can’t even 911 In heavily populated areas! Phone is not broken, an has been checked out. 

what gives. 

Responses

Official Employee

 • 

26 Messages

2 d ago

I know it's important to have a working phone, and appreciate you already doing those troubleshooting steps. I recommend calling our Xfinity Mobile Team at 888-936-4968 from a different phone, if you have one available, for further assistance. If you have already reached out to the team and still need help, please send us a private message with your name and address associated with the account. 

 

To send a private message:

• Click "Sign In" if necessary • Click the "Peer to peer chat" icon (upper right corner of this page) • Click the "New message" (pencil and paper) icon • Type "Xfinity Support" in the to line and select "Xfinity Support" from the drop-down list • Type your message in the text area near the bottom of the window • Press Enter to send your message. 

New to the Community?

Start Here